summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-26 20:51:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-26 20:52:23 +0100
commit06daa4f02225c9ca702b4a86479109cb5b2518ec (patch)
tree767e1ba836861e8d37505c577db9ed8ece3a9fe1 /sci-mathematics/cryptominisat
parentdev-libs/starpu: Stabilize 1.3.9 arm, #828292 (diff)
downloadgentoo-06daa4f02225c9ca702b4a86479109cb5b2518ec.tar.gz
gentoo-06daa4f02225c9ca702b4a86479109cb5b2518ec.tar.bz2
gentoo-06daa4f02225c9ca702b4a86479109cb5b2518ec.zip
sci-mathematics/cryptominisat: new package; add version 5.8.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest1
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild41
-rw-r--r--sci-mathematics/cryptominisat/metadata.xml20
3 files changed, 62 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
new file mode 100644
index 000000000000..9ed3ae1590c6
--- /dev/null
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -0,0 +1 @@
+DIST cryptominisat-5.8.0.tar.gz 943785 BLAKE2B 534af88a8432c7e3da63989cad8fd5e1491bd69a80b44977fa681e0356e857a505a82dc860b0d04d07987e3edae2861da67ec9dd781261e03a1120dc342b9759 SHA512 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
new file mode 100644
index 000000000000..d4517fca935e
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-single-r1 cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and Python interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 MIT"
+IUSE="+python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # tests require many convoluted bundled (git) modules
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_PYTHON_INTERFACE=$(usex python)
+ -DFORCE_PYTHON3=$(usex python)
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}
diff --git a/sci-mathematics/cryptominisat/metadata.xml b/sci-mathematics/cryptominisat/metadata.xml
new file mode 100644
index 000000000000..694a2c352cda
--- /dev/null
+++ b/sci-mathematics/cryptominisat/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ This system provides CryptoMiniSat, an advanced incremental SAT solver.
+ The system has 3 interfaces: command-line, C++ library and python.
+ The command-line interface takes a cnf as an input in the DIMACS format
+ with the extension of XOR clauses. The C++ and python interface mimics this
+ and also allows for incremental use: assumptions and multiple solve calls.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/msoos/cryptominisat/issues/</bugs-to>
+ <remote-id type="github">msoos/cryptominisat</remote-id>
+ </upstream>
+</pkgmetadata>