summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-03 21:11:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-03 21:11:41 +0200
commitd7fe2f7e671ec914e26a6d62800dfc62cda60a22 (patch)
treecb312a28a9f6a68881bec8c7b7b89db75f04b7c7 /sci-mathematics/cryptominisat
parentsys-block/megarc: do not require multilib profile (diff)
downloadgentoo-d7fe2f7e671ec914e26a6d62800dfc62cda60a22.tar.gz
gentoo-d7fe2f7e671ec914e26a6d62800dfc62cda60a22.tar.bz2
gentoo-d7fe2f7e671ec914e26a6d62800dfc62cda60a22.zip
sci-mathematics/cryptominisat: fix sysconfig import
Bug: https://github.com/msoos/cryptominisat/pull/679 Closes: https://bugs.gentoo.org/836684 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild4
-rw-r--r--sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch23
2 files changed, 26 insertions, 1 deletions
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
index d4517fca935e..8542bea79b7f 100644
--- a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-setup.py.in-sysconfig.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
diff --git a/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
new file mode 100644
index 000000000000..5280f27bbd8f
--- /dev/null
+++ b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
@@ -0,0 +1,23 @@
+index b3ab64af4..293eb1f80 100644
+--- a/python/setup.py.in
++++ b/python/setup.py.in
+@@ -27,7 +27,7 @@ import sys
+ import os
+ import platform
+ from distutils.core import setup, Extension
+-from distutils import sysconfig
++import sysconfig
+ from distutils.cmd import Command
+
+ __PACKAGE_VERSION__ = "0.2.0"
+@@ -59,8 +59,8 @@ def _init_posix(init):
+ Forces g++ instead of gcc on most systems
+ credits to eric jones (eric@enthought.com) (found at Google Groups)
+ """
+- def wrapper():
+- init()
++ def wrapper(vars):
++ init(vars)
+
+ config_vars = sysconfig.get_config_vars() # by reference
+ if config_vars["MACHDEP"].startswith("sun"):