summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-02-17 15:10:32 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-02-17 15:10:32 +0100
commit25d067881ac71f918b69864739c6e7fabbf5d9a4 (patch)
tree55750a1209e37f1216c7bf25619470bfe0bc92ac /sci-mathematics/cvc4
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-25d067881ac71f918b69864739c6e7fabbf5d9a4.tar.gz
gentoo-25d067881ac71f918b69864739c6e7fabbf5d9a4.tar.bz2
gentoo-25d067881ac71f918b69864739c6e7fabbf5d9a4.zip
sci-mathematics/cvc4: fix deps check
Closes: https://bugs.gentoo.org/833362 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics/cvc4')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild b/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild
index d15cbba2d1f8..ed74ecc20fba 100644
--- a/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CMAKE_MAKEFILE_GENERATOR=emake
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
@@ -23,8 +23,7 @@ RDEPEND="dev-libs/antlr-c
cln? ( sci-libs/cln )
!cln? ( dev-libs/gmp:= )"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
+BDEPEND="$(python_gen_any_dep '
dev-python/toml[${PYTHON_USEDEP}]
')
"
@@ -33,6 +32,10 @@ S="${WORKDIR}"/${PN^^}-archived-${PV}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+python_check_deps() {
+ has_version "dev-python/toml[${PYTHON_USEDEP}]"
+}
+
src_configure() {
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3