summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 16:30:42 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-18 10:01:07 +0100
commita5f3c97a845ed16803503483ac47bb61d9dfdbea (patch)
tree971279180d528b45fe9d9b2177e2479cc7704a07 /sci-mathematics/dataplot/files
parentdev-perl/GStreamer: Remove old (diff)
downloadgentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.tar.gz
gentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.tar.bz2
gentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.zip
sci-mathematics/dataplot: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-mathematics/dataplot/files')
-rw-r--r--sci-mathematics/dataplot/files/Makefile.am.2013122046
-rw-r--r--sci-mathematics/dataplot/files/configure.ac.200908212
-rw-r--r--sci-mathematics/dataplot/files/configure.ac.2013122076
-rw-r--r--sci-mathematics/dataplot/files/dataplot-20090821-opengl.patch4
4 files changed, 125 insertions, 3 deletions
diff --git a/sci-mathematics/dataplot/files/Makefile.am.20131220 b/sci-mathematics/dataplot/files/Makefile.am.20131220
new file mode 100644
index 000000000000..85e8c493b80f
--- /dev/null
+++ b/sci-mathematics/dataplot/files/Makefile.am.20131220
@@ -0,0 +1,46 @@
+bin_PROGRAMS = dataplot
+dataplot_SOURCES = dp1_linux.f \
+ dp2.f dp3.f dp4.f dp5.f dp6.f dp7.f dp8.f dp9.f dp10.f dp11.f \
+ dp12.f dp13.f dp14.f dp15.f dp16.f dp17.f dp18.f dp19.f dp20.f dp21.f \
+ dp22.f dp23.f dp24.f dp25.f dp26.f dp27.f dp28.f dp29.f dp30.f dp31.f \
+ dp32.f dp33.f dp34.f dp35.f dp36.f dp37.f dp38.f dp39.f dp40.f dp41.f \
+ dp42.f dp43.f dp44.f dp45.f dp46.f \
+ dpcalc.f dpdds2.f dpdds3.f dpdds.f edinit.f edmai2.f edsear.f edsub.f \
+ edwrst.f fit3b.f starpac.f tcdriv_nopc.f aqua_src.f cluster.f compgeom.f \
+ optimi.f libplot_src.c rldp.c main.f gks_src.f
+
+if ENABLE_GD
+dataplot_SOURCES += gd_src.c
+else
+dataplot_SOURCES += gd_src.f
+endif
+
+if ENABLE_GL
+dataplot_SOURCES += gl_src.c
+else
+dataplot_SOURCES += gl_src.f
+endif
+
+if ENABLE_X11
+dataplot_SOURCES += x11_src.c
+else
+dataplot_SOURCES += x11src.f
+endif
+
+dataplot_CFLAGS = @GL_CFLAGS@
+dataplot_LDADD = @GD_LIBS@ @GL_LIBS@ @X11_LIBS@ $(FLIBS) -lreadline
+
+# this is to remove ambiguity between the similar filenames
+# of the c and f77 version (shortcoming of automake)
+# the f77 versions are forced
+# the c versions objects are called dataplot-gd_src.o etc
+gd_src.o: gd_src.f
+ $(F77COMPILE) -c -o $@ $<
+gl_src.o: gl_src.f
+ $(F77COMPILE) -c -o $@ $<
+aqua_src.o: aqua_src.f
+ $(F77COMPILE) -c -o $@ $<
+libplot_src.o: libplot_src.f
+ $(F77COMPILE) -c -o $@ $<
+rldp.o: rldp.f
+ $(F77COMPILE) -c -o $@ $<
diff --git a/sci-mathematics/dataplot/files/configure.ac.20090821 b/sci-mathematics/dataplot/files/configure.ac.20090821
index 2343b23823dd..fa9a700aa060 100644
--- a/sci-mathematics/dataplot/files/configure.ac.20090821
+++ b/sci-mathematics/dataplot/files/configure.ac.20090821
@@ -1,5 +1,5 @@
AC_PREREQ(2.59)
-AC_INIT([dataplot], [20080225], [n.heckert@nist.gov])
+AC_INIT([dataplot], [20090821], [n.heckert@nist.gov])
AC_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR(config)
AM_MAINTAINER_MODE
diff --git a/sci-mathematics/dataplot/files/configure.ac.20131220 b/sci-mathematics/dataplot/files/configure.ac.20131220
new file mode 100644
index 000000000000..e2e1412fbfe8
--- /dev/null
+++ b/sci-mathematics/dataplot/files/configure.ac.20131220
@@ -0,0 +1,76 @@
+AC_PREREQ(2.59)
+AC_INIT([dataplot], [20131220], [n.heckert@nist.gov])
+AC_CONFIG_HEADER([config.h])
+AC_CONFIG_AUX_DIR(config)
+AM_MAINTAINER_MODE
+AM_INIT_AUTOMAKE([foreign])
+
+AC_PROG_CC
+AC_PROG_F77
+AC_F77_LIBRARY_LDFLAGS
+case $F77 in
+ *gfortran*) FFLAGS="${FFLAGS} -w -fno-range-check" ;;
+ *) ;;
+esac
+
+AC_CANONICAL_HOST
+case $host in
+ i?86*linux*) MAXOBV=100000 ;;
+ *64*linux*) MAXOBV=1000000 ;;
+esac
+AC_SUBST(MAXOBV)
+
+AC_ARG_ENABLE(gd,
+ [AS_HELP_STRING([--enable-gd], [Enable the gd device driver])],
+ [enable_gd=$enableval],
+ [enable_gd=no])
+
+AC_CHECK_LIB(plot, pl_closepl_r, ,
+ [AC_MSG_ERROR([plotutils libraries not found])])
+
+AC_ARG_ENABLE(gl,
+ [AS_HELP_STRING([--enable-gl], [Enable the OpenGL device driver])],
+ [enable_gl=$enableval],
+ [enable_gl=no])
+
+AC_ARG_ENABLE(X,
+ [AS_HELP_STRING([--enable-X], [Enable the X11 device driver])],
+ [enable_x11=$enableval],
+ [enable_x11=no])
+
+if test x"$enable_gd" = x"yes"; then
+ AC_CHECK_PROG(enable_gd, [gdlib-config],,
+ [AC_MSG_ERROR([GD driver requested but gdlib-config not found])])
+ GD_LIBS="`gdlib-config --libs` -lgd"
+ GD_CFLAGS="`gdlib-config --cflags`"
+ AC_SUBST(GD_LIBS)
+ AC_SUBST(GD_CFLAGS)
+fi
+AM_CONDITIONAL(ENABLE_GD, [test x"$enable_gd" = x"yes"] )
+
+if test x"$enable_gl" = x"yes"; then
+dnl hardcoded opengl libs (should be host/implementation dependent)
+ AC_CHECK_HEADER(GL/gl.h,,
+ [AC_MSG_ERROR([OpenGL driver requested but header gl.h not found])])
+ AC_CHECK_HEADER(GL/glu.h,,
+ [AC_MSG_ERROR([OpenGL driver requested but header glu.h not found])])
+ GL_CFLAGS="-DUNIX_OS -DAPPEND_UNDERSCORE -DSUBROUTINE_CASE"
+ AC_SUBST(GL_CFLAGS)
+
+ AC_CHECK_LIB(GL, glXCreateContext, GL_LIBS="-lGL",
+ [AC_MSG_ERROR([OpenGL driver requested but libraries not found])])
+ AC_CHECK_LIB(GLU, gluPerspective, GL_LIBS="-lGL -lGLU",
+ [AC_MSG_ERROR([OpenGL driver requested but libraries not found])])
+ GL_LIBS="-lGL -lGLU"
+ AC_SUBST(GL_LIBS)
+fi
+AM_CONDITIONAL(ENABLE_GL, [ test x"$enable_gl" = x"yes" ])
+
+if test x"$enable_x11" = x"yes"; then
+ PKG_CHECK_MODULES(X11, x11,,
+ [AC_MSG_ERROR([X11 driver requested but pkgconfig module not found])])
+fi
+AM_CONDITIONAL(ENABLE_X11, [ test x"$enable_x11" = x"yes" ])
+
+AC_CONFIG_FILES([Makefile DPCOPA.INC dp1_linux.f])
+AC_OUTPUT
diff --git a/sci-mathematics/dataplot/files/dataplot-20090821-opengl.patch b/sci-mathematics/dataplot/files/dataplot-20090821-opengl.patch
index 5810b6029b87..c2640db69c85 100644
--- a/sci-mathematics/dataplot/files/dataplot-20090821-opengl.patch
+++ b/sci-mathematics/dataplot/files/dataplot-20090821-opengl.patch
@@ -1,5 +1,5 @@
---- gl_src.c.orig 2001-02-28 16:45:56.000000000 -0500
-+++ gl_src.c 2008-04-10 17:03:03.000000000 -0400
+--- dpsrc_2013_12_20/gl_src.c.orig 2001-02-28 16:45:56.000000000 -0500
++++ dpsrc_2013_12_20/gl_src.c 2008-04-10 17:03:03.000000000 -0400
@@ -154,7 +154,7 @@
#include <stdio.h>
#include <stdlib.h>