summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-07 18:45:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-07 18:50:25 +0200
commit8c9c85bc0fcfdd20764d22e98bf89018864b284e (patch)
treea3f8dd708c4e3173cdb0796b008314bb796071ef /sci-mathematics/easycrypt
parentsci-mathematics/why3: bump to 1.5.0 (diff)
downloadgentoo-8c9c85bc0fcfdd20764d22e98bf89018864b284e.tar.gz
gentoo-8c9c85bc0fcfdd20764d22e98bf89018864b284e.tar.bz2
gentoo-8c9c85bc0fcfdd20764d22e98bf89018864b284e.zip
sci-mathematics/easycrypt: bump to 2022.04_p20220505
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest1
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2022.04_p20220505.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 099a037c9df2..1fd6d87372d0 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1,3 +1,4 @@
DIST easycrypt-1.0_pre20211210.tar.gz 1185137 BLAKE2B 3557a8b0423109a3b3e6e02f6d1ad88f07847d105015546c90b5a46cf514f1311390d3a6f6476c042420b91a62ad095919f7ab616adee2778165d9d081070730 SHA512 0043eac02e916dc46ed1cb4f278f148f915d09f336e904b1a711c18d62cda177e434fc13682ec095a085e458ba90ca8dd02968206af60f0b80a378f16b205553
DIST easycrypt-1.0_pre20220303.tar.gz 1193244 BLAKE2B f4d4b0661b7c58d9dd2c344efac45aa4257b46122cef81f98ced05792c1e4dd49d332421f09d0b11a28893096042a98a7415d06e1624aaa59cea0c71f17f4bb8 SHA512 bd9f1638631c9539aea3ee369705fbaafa06d575db395b3d170642af2450b7df735a18fe8f6aa6e8904eae62bdcd30743ab734f7c17c583ece7c146fee1bcf77
DIST easycrypt-2022.04.tar.gz 1277930 BLAKE2B 4bb68325b9894e28dcf33f2b78f63c029375ba4f77d0df06cedff3a26be768827c9fb25f49cc8ecc8a2d341191fb0b9371825979f0f7cd14c69b3ced16ddc32c SHA512 9234de7f28999a6de79a3ecd27d3499ffb15fe651b2a577cf0b49fc73e034bbe1b4d99c2a7aafd3df70d9b4e095d1ae09ed8ff7a7885c020f9e5c990afe9b592
+DIST easycrypt-2022.04_p20220505.tar.gz 1279876 BLAKE2B 10ae22e216b8a35973ad7d1dbffe1dba9ce328b67319577cd1a7fad957f08174d1651ee6c1bab8cdf12d8fda20cb85d5a334ad41dfb3e55f9ee8beb8a233a2eb SHA512 b1231e0be787a667c836d970236d47311e490443a66bc0a3834963557b32358ad9db2008e32d427d232f2a94c72afc65bd3330b6db1eb938335791ea997b4013
diff --git a/sci-mathematics/easycrypt/easycrypt-2022.04_p20220505.ebuild b/sci-mathematics/easycrypt/easycrypt-2022.04_p20220505.ebuild
new file mode 100644
index 000000000000..e83988a1a04e
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2022.04_p20220505.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=a49a0acf5f7e2776f6b10cd49f8a201ebab0cf03
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.5:= <sci-mathematics/why3-1.6:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}