summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-22 15:44:21 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-22 17:57:47 -0800
commit0b4cd49b52c25489cdaa12c0ba2b343b2e52cbc2 (patch)
tree1a961668e3cec0ea6ed4f764f2cc5e91a604f1da /sci-mathematics/geogebra-bin
parentgui-wm/sway: 1.7 bump :D (diff)
downloadgentoo-0b4cd49b52c25489cdaa12c0ba2b343b2e52cbc2.tar.gz
gentoo-0b4cd49b52c25489cdaa12c0ba2b343b2e52cbc2.tar.bz2
gentoo-0b4cd49b52c25489cdaa12c0ba2b343b2e52cbc2.zip
sci-mathematics/geogebra-bin: add 5.0.683.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sci-mathematics/geogebra-bin')
-rw-r--r--sci-mathematics/geogebra-bin/Manifest1
-rw-r--r--sci-mathematics/geogebra-bin/geogebra-bin-5.0.683.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/geogebra-bin/Manifest b/sci-mathematics/geogebra-bin/Manifest
index a5abac0caa19..3212bbde44c0 100644
--- a/sci-mathematics/geogebra-bin/Manifest
+++ b/sci-mathematics/geogebra-bin/Manifest
@@ -1,2 +1,3 @@
DIST GeoGebra-Linux-Portable-5-0-604-0.tar.bz2 138245005 BLAKE2B 589b12a60161ca07e6da82953aeda69a2ed7302634df9078cb997000e2b77486aa1f4dfcbc1daddfddf0b425574ad927c97e0a08d70d708a209eaf0af86d9756 SHA512 ccf190f436504727dc9c6fa10adbd2d0a72a87b641e5b7ce2c7bc8ffe8c1baa00d97b3d2b619f32f1c50b28d5c72b0e0b15619e9c8be74ad8c8fb5afbe66c9a3
+DIST GeoGebra-Linux-Portable-5-0-683-0.tar.bz2 131095393 BLAKE2B bef756bec904e40e06823de7121deb9755bd3523040018a826dcd78e5e8563095f7e4b16a90cad34e14d04628706c1d5a56856d389bd8d599d5588d875ff9b11 SHA512 a55e05bbb7acb6f4512ae3163312fd19095f32b9a3beed09ff12e8af2389dae2bb916af816aa50ee6645f4eb4b78936f3bc497312dc9446d8e1464830cd7b717
DIST Geogebra.svg 522 BLAKE2B 8c11d037bd8af7af571abc2bba0a8610f0ed5c1cea46fdc47a40d0176e5ea3b7ad4700601a3094b1aa15012f769883c7f5cb60a70f4ed400df57e3b0610271e9 SHA512 a54fedd530d1c803e14d6f44ab7341d9f1ae17fb6b6496bd21788ad1b88b0977d574db6de199e9168543a03dff73ab19e3c50793ec91750ff5fff4a4b7af408d
diff --git a/sci-mathematics/geogebra-bin/geogebra-bin-5.0.683.0.ebuild b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.683.0.ebuild
new file mode 100644
index 000000000000..3749e86ddc99
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.683.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop prefix xdg
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Mathematics software for geometry"
+HOMEPAGE="https://www.geogebra.org"
+SRC_URI="https://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-${MY_PV}.tar.bz2
+ https://dev.gentoo.org/~gyakovlev/distfiles/Geogebra.svg"
+
+LICENSE="Geogebra CC-BY-NC-SA-3.0 GPL-3 Apache-2.0 BSD-2 BSD BSD-4 colt EPL-1.0 icu LGPL-2.1 LGPL-2.1+ MIT W3C || ( GPL-2 CDDL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+RDEPEND="
+ dev-java/java-config
+ || (
+ dev-java/openjdk:8[javafx]
+ dev-java/openjdk:11[javafx]
+ )
+ !sci-mathematics/geogebra
+"
+
+# no tests
+RESTRICT="test"
+
+src_unpack() {
+ default
+ mv -v GeoGebra-Linux-Portable-* "${P}" || die
+ rm -rf "${P}/jre"* || die
+ rm -f "${P}/geogebra-portable" || die
+}
+
+src_prepare() {
+ eapply_user
+}
+
+src_install() {
+ insinto /opt
+ doins -r geogebra
+ newbin "$(prefixify_ro "${FILESDIR}"/geogebra.sh)" geogebra
+
+ fperms 0755 /opt/geogebra/geogebra
+ doicon "${DISTDIR}/Geogebra.svg"
+ make_desktop_entry geogebra Geogebra Geogebra Science
+}
+
+src_test() {
+ ewarn "package has no tests"
+}