summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-15 09:34:01 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-15 09:49:45 -0400
commitee4164ea823436d8d4ba9f9f3ee0ca517de4141e (patch)
treef955c271788f65180ab9c94a7e06590a7cd4d595 /sci-mathematics/gfan/gfan-0.6.2.ebuild
parentdev-perl/PlRPC: Remove old 0.202.0-r2 (diff)
downloadgentoo-ee4164ea823436d8d4ba9f9f3ee0ca517de4141e.tar.gz
gentoo-ee4164ea823436d8d4ba9f9f3ee0ca517de4141e.tar.bz2
gentoo-ee4164ea823436d8d4ba9f9f3ee0ca517de4141e.zip
sci-mathematics/gfan: disable test that hangs on x86.
The "0602ResultantFanProjection" test hangs on x86, leading to a build failure. Disabling this test looks as simple as deleting it from the source tree, which the ebuild now does in src_prepare(). Bug: https://bugs.gentoo.org/717112 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/gfan/gfan-0.6.2.ebuild')
-rw-r--r--sci-mathematics/gfan/gfan-0.6.2.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-mathematics/gfan/gfan-0.6.2.ebuild b/sci-mathematics/gfan/gfan-0.6.2.ebuild
index eac7123f2621..44e051550034 100644
--- a/sci-mathematics/gfan/gfan-0.6.2.ebuild
+++ b/sci-mathematics/gfan/gfan-0.6.2.ebuild
@@ -29,9 +29,20 @@ PATCHES=(
pkg_setup() {
tc-export CC CXX
+
+ # This should really go in cppflags, but that doesn't work with
+ # gfan's hand-written Makefile.
append-cxxflags -DNOCDDPREFIX
}
+src_prepare() {
+ default
+
+ # This test hangs on x86, bug 717112.
+ rm -r testsuite/0602ResultantFanProjection || \
+ die "unable to disable test 0602ResultantFanProjection"
+}
+
src_configure() {
# The upstream Makefile says that GCC produces bad code with -O3.
replace-flags "-O3" "-O2"