summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Fernández i Marín <xavier.fim@gmail.com>2015-10-30 10:05:15 +0100
committerXavier Fernández i Marín <xavier.fim@gmail.com>2015-10-30 10:05:15 +0100
commit241a72969aecd4e8c67dadfede0b867f51b4df92 (patch)
treea1ee79e44a3f085e897ba19da0ea718aa07eb850 /sci-mathematics/jags/jags-4.0.0.ebuild
parentmedia-libs/libmatroska: x86 stable wrt bug #564426 (diff)
downloadgentoo-241a72969aecd4e8c67dadfede0b867f51b4df92.tar.gz
gentoo-241a72969aecd4e8c67dadfede0b867f51b4df92.tar.bz2
gentoo-241a72969aecd4e8c67dadfede0b867f51b4df92.zip
sci-mathematics/jags Version bump (solves bug #562644).
Diffstat (limited to 'sci-mathematics/jags/jags-4.0.0.ebuild')
-rw-r--r--sci-mathematics/jags/jags-4.0.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/jags/jags-4.0.0.ebuild b/sci-mathematics/jags/jags-4.0.0.ebuild
new file mode 100644
index 000000000000..a790fd62f361
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://mcmc-jags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/4.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo docs)
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc "${BUILD_DIR}"/doc/manual/*.pdf
+}