summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Fernández i Marín <xavier.fim@gmail.com>2015-10-30 10:05:15 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-21 20:11:14 +0100
commitb1376251f4604303695ee2c6949d825bceb82b71 (patch)
tree7001c806282582c80065238dd16801242ce6abad /sci-mathematics/jags/jags-4.1.0.ebuild
parentwww-client/google-chrome-unstable: automated update (diff)
downloadgentoo-b1376251f4604303695ee2c6949d825bceb82b71.tar.gz
gentoo-b1376251f4604303695ee2c6949d825bceb82b71.tar.bz2
gentoo-b1376251f4604303695ee2c6949d825bceb82b71.zip
sci-mathematics/jags: version bump
Diffstat (limited to 'sci-mathematics/jags/jags-4.1.0.ebuild')
-rw-r--r--sci-mathematics/jags/jags-4.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/jags/jags-4.1.0.ebuild b/sci-mathematics/jags/jags-4.1.0.ebuild
new file mode 100644
index 000000000000..fc1d9f9f58e5
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://mcmc-jags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/4.x/Source/${MYP}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(usex doc docs "")
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc "${BUILD_DIR}"/doc/manual/*.pdf
+}