summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-11-25 19:53:10 -0500
committerMichael Orlitzky <mjo@gentoo.org>2021-11-25 19:53:28 -0500
commitd1bd5a544b917ad2ff1d1a6b5e9c4b4173128b0d (patch)
tree9f7d91c9f3274486a5e891eea4064e4d72547710 /sci-mathematics/lcalc
parentgames-emulation/ppsspp: bump to 1.12.3 (diff)
downloadgentoo-d1bd5a544b917ad2ff1d1a6b5e9c4b4173128b0d.tar.gz
gentoo-d1bd5a544b917ad2ff1d1a6b5e9c4b4173128b0d.tar.bz2
gentoo-d1bd5a544b917ad2ff1d1a6b5e9c4b4173128b0d.zip
sci-mathematics/lcalc: new upstream version 2.0.4.
Better upstream support for clang/libc++. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/lcalc')
-rw-r--r--sci-mathematics/lcalc/Manifest1
-rw-r--r--sci-mathematics/lcalc/lcalc-2.0.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-mathematics/lcalc/Manifest b/sci-mathematics/lcalc/Manifest
index 7b3b0435da9e..e39c6f601a36 100644
--- a/sci-mathematics/lcalc/Manifest
+++ b/sci-mathematics/lcalc/Manifest
@@ -1 +1,2 @@
DIST lcalc-2.0.3.tar.xz 825904 BLAKE2B c2daab62de1d5bfb024a8246a965d850480cf313efe4f0ddb7561c28d2cae2aa231fea5c07e073d21e04cfcf2b558f931472825f9100e6ab4585ac87d80b4d3a SHA512 33d7cff04d88b62775a69b5b38eea41c24bdb88592d5185fbf9c13ea0c62a7c07c041f7f4e5c06415a3983b0ba369f3c9766a556090a6282e1cd7003ad25ba46
+DIST lcalc-2.0.4.tar.xz 832620 BLAKE2B b37d9ebf2d1df88b04fba6c9834ebc977ed483ad399cdaccf5347e4aee2295e26615a0331f6386209fe87424a8444f198a9ec1173d88e741dd6f2b9246ae287c SHA512 760634a66184f4777b8849859322c4b31f4bdd9d6644a44a2129e47e2f691424b126953353273f7a57dba7236cffe4f35504bb9d03fdd152f74c7d1a48dc712c
diff --git a/sci-mathematics/lcalc/lcalc-2.0.4.ebuild b/sci-mathematics/lcalc/lcalc-2.0.4.ebuild
new file mode 100644
index 000000000000..26818c40aafb
--- /dev/null
+++ b/sci-mathematics/lcalc/lcalc-2.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line utility and library for L-function computations"
+HOMEPAGE="https://gitlab.com/sagemath/lcalc"
+SRC_URI="https://gitlab.com/sagemath/lcalc/uploads/4d84022aa5285414eb547121b783601a/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+# The subslot is the libLfunction soname major version
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+# Omit USE=mpfr for now because it's broken upstream:
+#
+# https://gitlab.com/sagemath/lcalc/-/issues/7
+#
+IUSE="+double double-double quad-double pari"
+REQUIRED_USE="^^ ( double double-double quad-double )"
+
+BDEPEND="dev-util/gengetopt"
+DEPEND="double-double? ( sci-libs/qd:= )
+ quad-double? ( sci-libs/qd:= )
+ pari? ( sci-mathematics/pari:= )"
+REPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with pari) \
+ --enable-precision="$(usev double)$(usev double-double)$(usev quad-double)"
+}