summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-15 09:12:07 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-12-15 09:15:50 -0500
commitf08215307fd1137f65bef1cced7b6c8ca16b4f42 (patch)
tree7559778bc5dedd3f985090468d4c5b34fde229e6 /sci-mathematics/nauty
parentwww-apps/webmcp: fix c99 (diff)
downloadgentoo-f08215307fd1137f65bef1cced7b6c8ca16b4f42.tar.gz
gentoo-f08215307fd1137f65bef1cced7b6c8ca16b4f42.tar.bz2
gentoo-f08215307fd1137f65bef1cced7b6c8ca16b4f42.zip
sci-mathematics/nauty: add 2.8.8
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/nauty')
-rw-r--r--sci-mathematics/nauty/Manifest2
-rw-r--r--sci-mathematics/nauty/nauty-2.8.8.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/Manifest b/sci-mathematics/nauty/Manifest
index 111f546fdc06..de80d1d6f226 100644
--- a/sci-mathematics/nauty/Manifest
+++ b/sci-mathematics/nauty/Manifest
@@ -1,3 +1,5 @@
DIST nauty-includes.patch 2530 BLAKE2B 8789bc2f65b89aa3bbf27e517f1c56340f9bde089ef54aa28757c66c3954b5c54e8a09b6989ad8d57098970240dd1838baa0003766fe10c7f6c32041abf461e3 SHA512 d11f530fecb86edc9e95f0b4d91240778047c0e84d6259c80490358baf0a3eeaa112acfe1fcdb594da6c6e17855f5e21cb75c88446b8d6d9e96402be0e5e6af2
DIST nauty2_8_6.tar.gz 1546765 BLAKE2B be8aa8ef816c8833a79876e6bf99b0dc4a23922f48684c8a3272c01b0b4eb64959366cae363fbda4200354a0833942b64e85c009fc35a3d6fa02f9b74c9b9a74 SHA512 9bc597d4341a6a67aece0ad95ecd4a649f675def73e97af1d215cf7399cbd3fb8e39f140cbd6f69740f2083c7a5739d5089e746bb3f831250709e0d2b43548b5
+DIST nauty2_8_8.tar.gz 2302360 BLAKE2B 4a37b345b239de11948d180f306e984dfec4aa26eb2720d0f0f09acd120a60b4f678375baa10d3f64f3e2f501c35cbfa58e10fc44252eb7b952a1592727a3b7f SHA512 c0495256b92b0742e7f0a3ad8b43f400e7b4bc4b58dff560e7d0a868f392b0462424566b8ebba5ec08499551eab091b6a8e2c0ddba4953ab7592906034812c18
DIST nauty_2.8.6+ds-1.debian.tar.xz 62852 BLAKE2B fcbbed54b10d9dd4bdf82d8a72ef91866a235c7679266b8f395e2fe6b44a679e98f85462a42037094d856130d5456d9989749c416932f895bc17df8ef32241a2 SHA512 3784e0ec15c64ea6850f9198c61af3924fcedf1ffa4715fbd53a9bd1cd7defd69b543a8d4e6d46ef727918661409e2de77c89c3ca79f36769c1335b30bdd305c
+DIST nauty_2.8.8+ds-1.debian.tar.xz 65176 BLAKE2B 3615819098169caf1648271c0725e146c87ab794776c02f5bd77b7092a2c1d9b93d663ef4a9cf027fda956d40f24bb99a909f89a4564b99429b67f781d39cfc2 SHA512 f81aa3c4a142c4efa5ce97c241f95cba9916d49f02c2b3dfbd76227f2db20ec5e2a3ebe371c5748681fc3492df9ff9bca2456d76e1c70e435aa5baf1522391d5
diff --git a/sci-mathematics/nauty/nauty-2.8.8.ebuild b/sci-mathematics/nauty/nauty-2.8.8.ebuild
new file mode 100644
index 000000000000..175fa68eeca6
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.8.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PV=${PV//./_}
+DEBIAN_PATCH_VERSION=1
+
+DESCRIPTION="Computing automorphism groups of graphs and digraphs"
+HOMEPAGE="https://pallini.di.uniroma1.it/"
+
+SRC_URI="https://pallini.di.uniroma1.it/${PN}${MY_PV}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}+ds-${DEBIAN_PATCH_VERSION}.debian.tar.xz
+ https://src.fedoraproject.org/rpms/nauty/raw/rawhide/f/nauty-includes.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="cpu_flags_x86_popcnt examples"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="dev-libs/gmp:0
+ sys-libs/zlib
+ sci-mathematics/cliquer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+DOCS=( schreier.txt formats.txt changes24-28.txt )
+
+PATCHES=(
+ "${WORKDIR}/debian/patches/upstream-fix-gt_numorbits.patch"
+ "${WORKDIR}/debian/patches/upstream-zlib-dimacs2g.patch"
+ "${WORKDIR}/debian/patches/upstream-C2help2man.patch"
+ "${WORKDIR}/debian/patches/upstream-autotoolization.patch"
+ "${DISTDIR}/nauty-includes.patch"
+ "${WORKDIR}/debian/patches/unbundle-cliquer.patch"
+ "${WORKDIR}/debian/patches/format.patch"
+ "${WORKDIR}/debian/patches/uninitialized.patch"
+ "${WORKDIR}/debian/patches/fall-off.patch"
+ "${WORKDIR}/debian/patches/noreturn.patch"
+)
+
+src_prepare() {
+ default
+ rm makefile || die
+
+ # The debian patch looks for <cliquer.h>, but the autotools-form of
+ # cliquer installs that header as <cliquer/cliquer.h>.
+ sed -e 's~<cliquer\.h>~<cliquer/cliquer\.h>~' -i nautycliquer.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static \
+ --enable-tls \
+ --enable-generic \
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+}
+
+src_test() {
+ # It arrives non-executable in v2.8.8.
+ chmod +x runalltests || die
+ default
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc nautyex*.c
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}