summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-06 03:57:14 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-06 03:57:14 +0700
commit25bdc1845b1dc6552bcb5e579cb174e152bda98b (patch)
tree2b4533c6c3a5cc939e6e4ec40c04b9f635265010 /sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
parentsci-mathematics/ginac: bump to 1.7.2 (diff)
downloadgentoo-25bdc1845b1dc6552bcb5e579cb174e152bda98b.tar.gz
gentoo-25bdc1845b1dc6552bcb5e579cb174e152bda98b.tar.bz2
gentoo-25bdc1845b1dc6552bcb5e579cb174e152bda98b.zip
sci-mathematics/nestedsums: bump to 1.5.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
new file mode 100644
index 000000000000..80fa329a76ce
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
+IUSE="doc"
+SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ default
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml reference/html/*
+ fi
+}