summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-08-09 09:06:37 +0200
committerDavid Seifert <soap@gentoo.org>2016-08-09 09:08:05 +0200
commit8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c (patch)
treed26f3b37ebc38267e4beb505b159b7cefc8149bb /sci-mathematics/octave/octave-3.6.4.ebuild
parentkde-apps/kgamma -> kde-plasma/kgamma (diff)
downloadgentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.tar.gz
gentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.tar.bz2
gentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.zip
sci-mathematics/octave: Remove automagic dep on media-gfx/graphicsmagick
Gentoo-Bug: 590280 * Explicitly select dependency on the basis of USE="graphicsmagick" vs USE="imagemagick" only. Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics/octave/octave-3.6.4.ebuild')
-rw-r--r--sci-mathematics/octave/octave-3.6.4.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sci-mathematics/octave/octave-3.6.4.ebuild b/sci-mathematics/octave/octave-3.6.4.ebuild
index db636ad50e32..f25a0fdee2c2 100644
--- a/sci-mathematics/octave/octave-3.6.4.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -29,10 +30,8 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
@@ -112,12 +111,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi