summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-11-26 13:19:45 -0600
committerSam James <sam@gentoo.org>2020-11-26 19:41:31 +0000
commit65b93994396ad5d40389327728e3457b24c29d61 (patch)
tree4d51af8e234368bacf20c94ab65ddbf5200d4db2 /sci-mathematics/pspp
parentapp-misc/mc: drop project desktop-misc (diff)
downloadgentoo-65b93994396ad5d40389327728e3457b24c29d61.tar.gz
gentoo-65b93994396ad5d40389327728e3457b24c29d61.tar.bz2
gentoo-65b93994396ad5d40389327728e3457b24c29d61.zip
sci-mathematics/pspp: security cleanup (<1.2.0-r1)
Bug: https://bugs.gentoo.org/679392 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/18416 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics/pspp')
-rw-r--r--sci-mathematics/pspp/pspp-1.2.0.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/sci-mathematics/pspp/pspp-1.2.0.ebuild b/sci-mathematics/pspp/pspp-1.2.0.ebuild
deleted file mode 100644
index b0978a19cfa8..000000000000
--- a/sci-mathematics/pspp/pspp-1.2.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils elisp-common ltprune
-
-DESCRIPTION="Program for statistical analysis of sampled data"
-HOMEPAGE="https://www.gnu.org/software/pspp/pspp.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cairo doc emacs examples gtk ncurses nls perl postgres static-libs"
-
-RDEPEND="
- dev-libs/libxml2:2=
- sci-libs/gsl:0=
- sys-devel/gettext:0=
- sys-libs/readline:0=
- sys-libs/zlib:0=
- virtual/libiconv
- cairo? ( x11-libs/cairo:0=[svg] )
- emacs? ( >=app-editors/emacs-23.1:* )
- gtk? (
- x11-libs/gtk+:3=
- x11-libs/gtksourceview:3.0=
- x11-libs/spread-sheet-widget )
- ncurses? ( sys-libs/ncurses:0= )
- postgres? ( dev-db/postgresql:=[server] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( virtual/latex-base )"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_enable static-libs static) \
- $(use_with cairo) \
- $(use_with gtk gui) \
- $(use_with ncurses libncurses) \
- $(use_with perl perl-module) \
- $(use_with postgres libpq)
-}
-
-src_compile() {
- default
- use doc && emake html pdf
- use emacs && elisp-compile *.el
-}
-
-src_install() {
- default
- if use doc; then
- dodoc doc/pspp{,-dev}.pdf
- insinto /usr/share/doc/${PF}/html
- dodoc -r doc/pspp{,-dev}.html
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- prune_libtool_files --all
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}