summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-12-07 23:00:30 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-12-07 23:08:41 +0300
commitfba74311732b0000c59669bed487f7cf6ea511c2 (patch)
tree2b9a54284e9c7031a5a149150a5db8f92f5eb4db /sci-mathematics/pspp
parentx11-libs/spread-sheet-widget: New dep for pspp (diff)
downloadgentoo-fba74311732b0000c59669bed487f7cf6ea511c2.tar.gz
gentoo-fba74311732b0000c59669bed487f7cf6ea511c2.tar.bz2
gentoo-fba74311732b0000c59669bed487f7cf6ea511c2.zip
sci-mathematics/pspp: Version bump
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sci-mathematics/pspp')
-rw-r--r--sci-mathematics/pspp/Manifest1
-rw-r--r--sci-mathematics/pspp/pspp-1.2.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/pspp/Manifest b/sci-mathematics/pspp/Manifest
index 556d24960b2a..0049a628c147 100644
--- a/sci-mathematics/pspp/Manifest
+++ b/sci-mathematics/pspp/Manifest
@@ -1,2 +1,3 @@
DIST pspp-0.10.1.tar.gz 7269109 BLAKE2B 5f488b1bbe9d4cf833d847cd035485827e7e518fb82f0e5df98418e919da54553475e91fd8529df8819ee71d853fb8bdd079e27a9b8587b40074701a7d71a8c2 SHA512 a7f4eec3858340743ff845e67028af76d79a58968ceaa19a87e0443751917b2d70251e53231ecce15c937c9640ac733e00603baa76b4266d693375ab70b870b5
DIST pspp-0.10.2.tar.gz 7316470 BLAKE2B 9bbccfc8151d83613f5c4f49f285959c6b9e74bdc99edb95dc719561fb05c01e54b10fc5b3a58b9e5beeae199235d0d936a6ee08277fe7c710c3e40ca6c389f7 SHA512 7d6656c03da46b088e87cba7a947d1e56031ff50d704be8201a38563515cf5cf324a05f1d4999ba8aec7b2269a8fdbd09374a11374c9c1b9dd6d78d34fda4b76
+DIST pspp-1.2.0.tar.gz 7213194 BLAKE2B f468c6e025f996c9f806fb03e94a4497f02b774c509457cc6295bbefe37abc7e2ecf10d2876c8cff9a979d7a4264c7c185e1cec5fd1d5f2f00f1c6eae4da775e SHA512 49eed2b55f10584abba18ff7d2020fd08691bbc1a3c2f332e6d283e32aa84e0abdae6092d17db9c1a539c63d85ecdfcc2dad40c94a06904b8893a1976e5e48d3
diff --git a/sci-mathematics/pspp/pspp-1.2.0.ebuild b/sci-mathematics/pspp/pspp-1.2.0.ebuild
new file mode 100644
index 000000000000..85f03f048b0b
--- /dev/null
+++ b/sci-mathematics/pspp/pspp-1.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils elisp-common
+
+DESCRIPTION="Program for statistical analysis of sampled data"
+HOMEPAGE="https://www.gnu.org/software/pspp/pspp.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cairo doc emacs examples gtk ncurses nls perl postgres static-libs"
+
+RDEPEND="
+ dev-libs/libxml2:2=
+ sci-libs/gsl:0=
+ sys-devel/gettext:0=
+ sys-libs/readline:0=
+ sys-libs/zlib:0=
+ virtual/libiconv
+ cairo? ( x11-libs/cairo:0=[svg] )
+ emacs? ( virtual/emacs )
+ gtk? (
+ x11-libs/gtk+:3=
+ x11-libs/gtksourceview:3.0=
+ x11-libs/spread-sheet-widget )
+ ncurses? ( sys-libs/ncurses:0= )
+ postgres? ( dev-db/postgresql:=[server] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_with cairo) \
+ $(use_with gtk gui) \
+ $(use_with ncurses libncurses) \
+ $(use_with perl perl-module) \
+ $(use_with postgres libpq)
+}
+
+src_compile() {
+ default
+ use doc && emake html pdf
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ default
+ if use doc; then
+ dodoc doc/pspp{,-dev}.pdf
+ insinto /usr/share/doc/${PF}/html
+ dodoc -r doc/pspp{,-dev}.html
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ prune_libtool_files --all
+}
+
+pkg_postinst () {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}