summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-09-04 21:32:57 +1000
committerMark Wright <gienah@gentoo.org>2015-09-04 21:32:57 +1000
commit5744b9abe4fd4b23440d4c8d52d80666d99d8841 (patch)
tree550ae64a49cc422927c9c55abc9ae56b7c947158 /sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
parentapp-admin/mms-agent: version bump (diff)
downloadgentoo-5744b9abe4fd4b23440d4c8d52d80666d99d8841.tar.gz
gentoo-5744b9abe4fd4b23440d4c8d52d80666d99d8841.tar.bz2
gentoo-5744b9abe4fd4b23440d4c8d52d80666d99d8841.zip
sci-mathematics/rstudio: Bump to rstudio-0.99.482.
Avoid the rest of the oracle-jdk-bin-1.8.0.60 sandbox violations F: mkdir S: deny P: /root/.oracle_jre_usage. in rstudio-0.99.473-r1 and rstudio-0.99.482. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild')
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild b/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
index b247a88618c5..3682c5ca0fd0 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
@@ -12,11 +12,14 @@ inherit eutils user cmake-utils gnome2-utils pam versionator fdo-mime java-pkg-2
# * do src_test (use junit from tree?)
# update from scripts in dependencies/common
+# egrep '(GWT_SDK_VER=|GIN_VER=|SELENIUM_VER=|CHROMEDRIVER_VER=)' dependencies/common/install-gwt
GWT_VER=2.7.0
GIN_VER=1.5
SELENIUM_VER=2.37.0
CHROMEDRIVER_VER=2.7
+# grep 'PANDOC_VERSION=' dependencies/common/update-pandoc
PANDOC_VER=1.13.1
+# ls dependencies/common/*.tar.gz
PACKRAT_VER=0.98.1000
RMARKDOWN_VER=0.98.1000
SHINYAPPS_VER=0.98.1000
@@ -167,6 +170,12 @@ src_prepare() {
sed -e "s@Qt5Solutions_SingleApplication-2.6@${s}@g" \
-i "${S}"/src/cpp/desktop/CMakeLists.txt \
|| die
+
+ # Avoid some of the oracle-jdk-bin-1.8.0.60 sandbox violations F: mkdir S: deny
+ # P: /root/.oracle_jre_usage.
+ sed -e 's@\(\s*\)\(</classpath>\)@\1\2\n\1\<jvmarg value="-Duser.home=${env.T}"/>@g' \
+ -i "${S}"/src/gwt/build.xml \
+ || die
}
src_configure() {
@@ -185,10 +194,14 @@ src_configure() {
}
src_compile() {
+ # Avoid the rest of the oracle-jdk-bin-1.8.0.60 sandbox violations F: mkdir S: deny
+ # P: /root/.oracle_jre_usage.
+ export ANT_OPTS="-Duser.home=${T}"
cmake-utils_src_compile
}
src_install() {
+ export ANT_OPTS="-Duser.home=${T}"
cmake-utils_src_install
pax-mark m "${ED}usr/bin/rstudio"
doconfd "${FILESDIR}"/rstudio-server.conf