summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-05-25 19:06:23 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-05-25 20:26:53 -0500
commiteda33279083369e2c6a48e53f40f11dc5707a5d8 (patch)
tree87e49f9003cd7ec9f613d80afee3be27eef8128f /sci-mathematics/slepc/slepc-3.17.1.ebuild
parentsci-mathematics/petsc: add 3.17.1 (diff)
downloadgentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.tar.gz
gentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.tar.bz2
gentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.zip
sci-mathematics/slepc: add 3.17.1
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics/slepc/slepc-3.17.1.ebuild')
-rw-r--r--sci-mathematics/slepc/slepc-3.17.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/slepc/slepc-3.17.1.ebuild b/sci-mathematics/slepc/slepc-3.17.1.ebuild
new file mode 100644
index 000000000000..8aa85eac9d58
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.17.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="https://slepc.upv.es/"
+SRC_URI="https://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+ export PETSC_ARCH
+ export SLEPC_DIR="${S}"
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-lib="$(usex mpi "-lparpack,-larpack" "-larpack")"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}