summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-28 18:44:30 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-28 18:44:59 +0100
commiteb51ca1449d7cb1ed83dfbb05c6dbb7ba6a285ab (patch)
tree8d705f2770f8765c151f69e05686005efb3b82fe /sci-mathematics/smtinterpol
parentsci-mathematics/cadical: patch direct call to ar (diff)
downloadgentoo-eb51ca1449d7cb1ed83dfbb05c6dbb7ba6a285ab.tar.gz
gentoo-eb51ca1449d7cb1ed83dfbb05c6dbb7ba6a285ab.tar.bz2
gentoo-eb51ca1449d7cb1ed83dfbb05c6dbb7ba6a285ab.zip
sci-mathematics/smtinterpol: new package; add version 2.5_p20211018
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/smtinterpol')
-rw-r--r--sci-mathematics/smtinterpol/Manifest1
-rw-r--r--sci-mathematics/smtinterpol/files/smtinterpol-Version.template-version.patch11
-rw-r--r--sci-mathematics/smtinterpol/files/smtinterpol-build.xml-basename.patch12
-rw-r--r--sci-mathematics/smtinterpol/metadata.xml13
-rw-r--r--sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild41
5 files changed, 78 insertions, 0 deletions
diff --git a/sci-mathematics/smtinterpol/Manifest b/sci-mathematics/smtinterpol/Manifest
new file mode 100644
index 000000000000..4d43fb1c44cb
--- /dev/null
+++ b/sci-mathematics/smtinterpol/Manifest
@@ -0,0 +1 @@
+DIST smtinterpol-2.5_p20211018.tar.gz 10676726 BLAKE2B 27bed1f707241416f71d10ae33c39b7fe638b9650a26f3237409722a8782af3b09890dce9acf30ab2d0412cfbe94f57684850c51e486d3d7f7dddd8025021c8d SHA512 8630ae5f9cf3fdcbceffeeb1f199c2e21e27d0348d3aec5a7062ee5eb942c640661ae58603f273881f30f24630a92b041ea867086ce6d0a2eab5fdd924eb01c3
diff --git a/sci-mathematics/smtinterpol/files/smtinterpol-Version.template-version.patch b/sci-mathematics/smtinterpol/files/smtinterpol-Version.template-version.patch
new file mode 100644
index 000000000000..b6c5971be7ea
--- /dev/null
+++ b/sci-mathematics/smtinterpol/files/smtinterpol-Version.template-version.patch
@@ -0,0 +1,11 @@
+index bf87cd1..6ca4533 100644
+--- a/SMTInterpol/src/de/uni_freiburg/informatik/ultimate/smtinterpol/Version.template
++++ b/SMTInterpol/src/de/uni_freiburg/informatik/ultimate/smtinterpol/Version.template
+@@ -23,5 +23,5 @@ package de.uni_freiburg.informatik.ultimate.smtinterpol;
+ * @author Jochen Hoenicke
+ */
+ public interface Version {
+- public final static String VERSION = "${version}";
++ public final static String VERSION = "0";
+ }
+\ No newline at end of file
diff --git a/sci-mathematics/smtinterpol/files/smtinterpol-build.xml-basename.patch b/sci-mathematics/smtinterpol/files/smtinterpol-build.xml-basename.patch
new file mode 100644
index 000000000000..d6d2256826fd
--- /dev/null
+++ b/sci-mathematics/smtinterpol/files/smtinterpol-build.xml-basename.patch
@@ -0,0 +1,12 @@
+index e105c33..21295bf 100644
+--- a/build.xml
++++ b/build.xml
+@@ -32,7 +32,7 @@ stage: Upload new version to Maven Central (owner only)
+ <arg value="describe"/>
+ </exec>
+ <echo>Version is ${version}</echo>
+- <property name="jar.basename" value="${artifactId}-${version}"/>
++ <property name="jar.basename" value="${artifactId}"/>
+ <tstamp>
+ <format property="build.date" pattern="yyyy-MM-dd"/>
+ <format property="build.year" pattern="yyyy"/>
diff --git a/sci-mathematics/smtinterpol/metadata.xml b/sci-mathematics/smtinterpol/metadata.xml
new file mode 100644
index 000000000000..242a13366da1
--- /dev/null
+++ b/sci-mathematics/smtinterpol/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ultimate-pa/smtinterpol/issues/</bugs-to>
+ <remote-id type="github">ultimate-pa/smtinterpol</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild b/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
new file mode 100644
index 000000000000..495a57f37578
--- /dev/null
+++ b/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=32d7fa8751f668f9e9a18e4e96df3337b53d2150
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Interpolating SMT-solver that can compute Craig interpolants for various theories"
+HOMEPAGE="http://ultimate.informatik.uni-freiburg.de/smtinterpol/"
+SRC_URI="https://github.com/ultimate-pa/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${H}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-Version.template-version.patch
+ "${FILESDIR}"/${PN}-build.xml-basename.patch
+)
+
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ eant all
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ einstalldocs
+}