summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-27 14:07:02 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-27 14:07:02 +0100
commit6f0b9d2bc3952de477fefeaa68783e5dc27e4e2d (patch)
tree343fc1d41e1be2d6b62f07d68f564edbd675c026 /sci-mathematics/stp
parentdev-perl/Config-AutoConf-0.320.0: marked ~ppc-macos (diff)
downloadgentoo-6f0b9d2bc3952de477fefeaa68783e5dc27e4e2d.tar.gz
gentoo-6f0b9d2bc3952de477fefeaa68783e5dc27e4e2d.tar.bz2
gentoo-6f0b9d2bc3952de477fefeaa68783e5dc27e4e2d.zip
sci-mathematics/stp: dev-libs -> sci-mathematics
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/stp')
-rw-r--r--sci-mathematics/stp/Manifest1
-rw-r--r--sci-mathematics/stp/metadata.xml26
-rw-r--r--sci-mathematics/stp/stp-2.3.3.ebuild45
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-mathematics/stp/Manifest b/sci-mathematics/stp/Manifest
new file mode 100644
index 000000000000..e41280980dc7
--- /dev/null
+++ b/sci-mathematics/stp/Manifest
@@ -0,0 +1 @@
+DIST stp-2.3.3.tar.gz 2577550 BLAKE2B 9ebedf3cb8e6b50d037cfacbc14826bd4e6505d29a53b1fcc6580749f0637fe5f96619c166babdb3a52b18fb6337e49c02f5693e233effe84d0131d0e7402381 SHA512 a0b1bf419d8230e40ce0aee90d9c8c9d814aca300831c24b3576c75623362942abf20673c419f9f0ea1e0505bfae000dc65fdd818179f5759879b0b255f1b99a
diff --git a/sci-mathematics/stp/metadata.xml b/sci-mathematics/stp/metadata.xml
new file mode 100644
index 000000000000..511b06e39e35
--- /dev/null
+++ b/sci-mathematics/stp/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jeffrey@icurse.nl</email>
+ <name>Jeffrey Lin</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ STP is a constraint solver (or SMT solver) aimed at solving
+ constraints of bitvectors and arrays. These types of
+ constraints can be generated by program analysis tools, theorem
+ provers, automated bug finders, cryptographic attack tools,
+ intelligent fuzzers, model checkers, and by many other
+ applications.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">stp/stp</remote-id>
+ </upstream>
+ <use>
+ <flag name="python">Enable building the Python interface</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-mathematics/stp/stp-2.3.3.ebuild b/sci-mathematics/stp/stp-2.3.3.ebuild
new file mode 100644
index 000000000000..c88151911bae
--- /dev/null
+++ b/sci-mathematics/stp/stp-2.3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
+HOMEPAGE="https://stp.github.io/"
+SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=
+ sci-mathematics/minisat
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # replace static lib with $(get_libdir)
+ sed -i "s/set(LIBDIR lib/set(LIBDIR $(get_libdir)/" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ASSERTIONS="$(usex test)"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PYTHON_INTERFACE="$(usex python)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # don't install to /usr/man
+ doman "${D}/usr/man/man1/stp.1"
+ rm -r "${D}/usr/man" || die
+}