summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-16 07:02:32 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-17 20:57:49 -0400
commitfccf8fbb4fe4f89eb3fdfdc92680a9027b3a978a (patch)
treedee1395d7099214fa1d1eae9050a095089c10a74 /sci-mathematics/sympow/sympow-2.023.6.ebuild
parentprofiles: add Sympow-BSD to the MISC-FREE license group. (diff)
downloadgentoo-fccf8fbb4fe4f89eb3fdfdc92680a9027b3a978a.tar.gz
gentoo-fccf8fbb4fe4f89eb3fdfdc92680a9027b3a978a.tar.bz2
gentoo-fccf8fbb4fe4f89eb3fdfdc92680a9027b3a978a.zip
sci-mathematics/sympow: new package for symmetric power L-functions.
This is an actively-maintained fork of Mark Watkins's original sympow package (that is now impossible to find) by Debian's Jérôme Benoit. Sympow is a dependency of SageMath, and SageMath will soon be able to use the system's copy of sympow. Having this in Gentoo therefore avoids pointless rebuilds of sympow for Gentoo users of SageMath. Closes: https://bugs.gentoo.org/230449 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/sympow/sympow-2.023.6.ebuild')
-rw-r--r--sci-mathematics/sympow/sympow-2.023.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/sympow/sympow-2.023.6.ebuild b/sci-mathematics/sympow/sympow-2.023.6.ebuild
new file mode 100644
index 000000000000..4e5e5566a81b
--- /dev/null
+++ b/sci-mathematics/sympow/sympow-2.023.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Symmetric power elliptic curve L-functions"
+HOMEPAGE="https://gitlab.com/rezozer/forks/sympow/"
+SRC_URI="https://gitlab.com/rezozer/forks/sympow/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="Sympow-BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Pari is used at build time to generate data.
+BDEPEND="sys-apps/help2man
+ sci-mathematics/pari"
+DEPEND=""
+RDEPEND="sci-mathematics/pari"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dont-force-O3.patch"
+ "${FILESDIR}/${P}-no-pkgdatafilesbindir-warnings.patch"
+)
+
+DOCS=( HISTORY README.md )
+
+src_configure() {
+ export ADDBINPATH=yes
+ export PREFIX="${EPREFIX}/usr"
+
+ # This location still won't be writable, but we can at least add
+ # the EPREFIX that belongs there. Sympow uses $HOME/.sympow as a
+ # fallback (what we want) when its first attempt doesn't work.
+ export VARPREFIX="${EPREFIX}/var"
+
+ ./Configure || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}