summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/unuran/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/unuran/files')
-rw-r--r--sci-mathematics/unuran/files/unuran-1.8.0-nogsl.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/unuran/files/unuran-1.8.0-nogsl.patch b/sci-mathematics/unuran/files/unuran-1.8.0-nogsl.patch
new file mode 100644
index 000000000000..f6266532e83e
--- /dev/null
+++ b/sci-mathematics/unuran/files/unuran-1.8.0-nogsl.patch
@@ -0,0 +1,48 @@
+diff -Nur unuran-1.8.0.orig/configure.ac unuran-1.8.0/configure.ac
+--- unuran-1.8.0.orig/configure.ac 2010-12-22 05:11:07.000000000 +0000
++++ unuran-1.8.0/configure.ac 2010-12-22 05:15:35.000000000 +0000
+@@ -62,10 +62,6 @@
+ dnl libm: the standard math library
+ AC_CHECK_LIB([m], [sqrt])
+
+-dnl libmgsl: the GNU Scientific library
+-dnl (only used for experimental code)
+-AC_CHECK_LIB([gsl], [gsl_integration_qagiu])
+-
+ dnl Optional support for external uniform random number generators
+
+ dnl RngStream: Pierre L'Ecuyer's multiple random stream generator
+@@ -80,6 +76,11 @@
+ AX_ADD_URNG_LIB([gsl],[GSL],[random number generators from GNU Scientific Library],
+ [gsl],[gsl_rng_alloc],[gsl/gsl_rng.h])
+
++if test -n $UNURAN_SUPPORTS_GSL; then
++ AC_PATH_PROG(GSL_CONFIG, gsl-config, no)
++ LIBS="$LIBS `$GSL_CONFIG --libs`"
++fi
++
+ dnl Default URNG
+ AC_ARG_WITH(urng_default,
+ [AS_HELP_STRING([--with-urng-default],
+@@ -215,7 +216,8 @@
+ [],
+ [enable_experimental=no])
+ AS_IF([test "x$enable_experimental" = xyes],
+- [AC_DEFINE([USE_EXPERIMENTAL_CODE], [1],
++ [AC_CHECK_LIB([gsl], [gsl_integration_qagiu])
++ AC_DEFINE([USE_EXPERIMENTAL_CODE], [1],
+ [Define to 1 if you want to use experimental code])],
+ [])
+ AM_CONDITIONAL(ENABLE_EXPERIMENTAL, test x$enable_experimental = xyes)
+diff -Nur unuran-1.8.0.orig/tests/Makefile.am unuran-1.8.0/tests/Makefile.am
+--- unuran-1.8.0.orig/tests/Makefile.am 2010-12-22 05:11:07.000000000 +0000
++++ unuran-1.8.0/tests/Makefile.am 2010-12-22 05:11:19.000000000 +0000
+@@ -9,7 +9,7 @@
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/tests
+
+-noinst_LTLIBRARIES = libtestroutines.la
++check_LTLIBRARIES = libtestroutines.la
+ libtestroutines_la_SOURCES = testroutines.c testcounter.c
+
+ LDADD = \