summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-07-13 08:49:22 +0200
committerTupone Alfredo <tupone@gentoo.org>2018-07-13 08:49:22 +0200
commita30437c0c5fb08780562baccb5ff3eeb511bb6ad (patch)
tree6052a84a1558472a486e144484ee1afc116244c0 /sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
parentdev-ruby/parser: remove broken version (diff)
downloadgentoo-a30437c0c5fb08780562baccb5ff3eeb511bb6ad.tar.gz
gentoo-a30437c0c5fb08780562baccb5ff3eeb511bb6ad.tar.bz2
gentoo-a30437c0c5fb08780562baccb5ff3eeb511bb6ad.zip
sci-mathematics/why3-for-spark: Version bump to 2018
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild')
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
new file mode 100644
index 000000000000..e766cce4ade3
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MYP=${PN}-gpl-${PV}-src
+
+DESCRIPTION="Platform for deductive program verification"
+HOMEPAGE="http://why3.lri.fr/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dec7a447df26c27a43
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
+RESTRICT=strip
+
+DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
+ dev-ml/menhir
+ coq? ( sci-mathematics/coq )
+ doc? ( dev-tex/rubber )
+ gtk? ( dev-ml/lablgtk[sourceview] )
+ emacs? ( app-editors/emacs:* )
+ html? ( dev-tex/hevea )
+ hypothesis-selection? ( dev-ml/ocamlgraph )
+ zarith? ( dev-ml/zarith )
+ zip? ( >=dev-ml/camlzip-1.07 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+REQUIRED_USE="html? ( doc )"
+
+src_configure() {
+ econf \
+ --disable-pvs-libs \
+ --disable-isabelle-libs \
+ $(use_enable coq coq-libs) \
+ $(use_enable coq coq-tactic) \
+ $(use_enable doc) \
+ $(use_enable emacs emacs-compilation) \
+ $(use_enable gtk ide) \
+ $(use_enable html html-doc) \
+ $(use_enable hypothesis-selection) \
+ $(use_enable ocamlopt native-code) \
+ $(use_enable profiling) \
+ $(use_enable zarith) \
+ $(use_enable zip)
+}
+
+src_compile() {
+ emake -j1
+ if use ocamlopt; then
+ emake byte
+ fi
+ use doc && emake doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install
+ emake DESTDIR="${D}" -j1 install-lib
+ emake DESTDIR="${D}" install_spark2014_dev
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ if use doc; then
+ dodoc doc/manual.pdf
+ use html && dodoc -r doc/html
+ fi
+}