summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-11-03 20:21:48 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-11-03 20:21:48 +0700
commit2049135d35987d4bd58a458028e526b0a8e96bdb (patch)
tree8125027c1210def3f163de0adc1ea6bcd42c0e6f /sci-mathematics/wxmaxima
parentdev-libs/mpfr: amd64 stable wrt bug #693846 (diff)
downloadgentoo-2049135d35987d4bd58a458028e526b0a8e96bdb.tar.gz
gentoo-2049135d35987d4bd58a458028e526b0a8e96bdb.tar.bz2
gentoo-2049135d35987d4bd58a458028e526b0a8e96bdb.zip
sci-mathematics/wxmaxima: bump to 19.10.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-19.10.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index bf8fd10a8332..39e5a1d67247 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad
DIST wxmaxima-19.05.7.tar.gz 13832202 BLAKE2B 6afe37dfcefe3f1711cc1cc89e4c61071dff2d49c60742a6d64ece9fa029823f6e94e20eb69e6d6cd8ccad1f5f656670089d593752f4be4d179222f5f2090d53 SHA512 3a7caee5ab03eefd4d2811345678d7b74081b0a4315dcc7739dbf4d265d274bb47a93ace5980a30185a13f40c1c970a8e4ba444bdd64b8b9ebd3b9a263cc6c06
DIST wxmaxima-19.08.1.tar.gz 15153254 BLAKE2B 1bd48735ab95b078b9f35d7be623c1a16da6764649254579a2c2252ff858adb05e9408a85e5ed84dba6f15f879db761472276a5da77fa15e1c1823c678160aa3 SHA512 07f650144b8acd8295a45411185805185078f5236b67b33dac0f12308fc3b7522a6a46dfd2df35397c1d2fd5a357fb8d12473be4af576fcf09bda1e34352ae68
DIST wxmaxima-19.09.0.tar.gz 15153282 BLAKE2B 96cb2db8938b73fb2dc3547310109df581a780a0372687aed9957cd3434fcbec8fef23467543f854f7e6b2c302dba6f3d5a411b17ab83e886175a62dc3fac385 SHA512 fad35fa118e49834d2ff6d54fb1f7cb8675ca1caadbb43c526b7a313479412c1a6c69959a0820c17af0119fc926f66c31368598c9e212fac56305a96d7a39838
+DIST wxmaxima-19.10.0.tar.gz 16573758 BLAKE2B 9bee3f8822e9c9ed28058496f7c5c6b2358feeafad39d08d92f3e6ff382817a8a7fd3e33b821f6faba3863f4c8871bc3bebee2b9d97ec6ccfdbfd7c0f7d44940 SHA512 39681cefb81a3816b7daeef7df5b23f57f3a4572ff34396fd447829ceaf6505d09f730255d3c44dd48232879b9994f26a9f86801fe333e15483026d864efdf14
diff --git a/sci-mathematics/wxmaxima/wxmaxima-19.10.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-19.10.0.ebuild
new file mode 100644
index 000000000000..b22b9bbbbd26
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-19.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f "${S}"/locales/manual/${1}.po
+ rm -f "${S}"/locales/wxwin/${1}.po
+ rm -f "${S}"/info/${PN}.${1}.md
+ rm -f "${S}"/info/${PN}.${1}.html
+ }
+ l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/wxmaxima.hhp /usr/share/doc/${PF}/wxmaxima_tr.hhp
+ cmake-utils_src_install
+}