summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-08-18 22:39:02 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-08-18 22:39:02 +0700
commit93b10ca8d4183db22c121f186549c9f84d702ef2 (patch)
treec836b01049cd0fe87420910287a9384d22baabf9 /sci-mathematics/wxmaxima
parentsci-mathematics/wxmaxima: cleaning old versions (diff)
downloadgentoo-93b10ca8d4183db22c121f186549c9f84d702ef2.tar.gz
gentoo-93b10ca8d4183db22c121f186549c9f84d702ef2.tar.bz2
gentoo-93b10ca8d4183db22c121f186549c9f84d702ef2.zip
sci-mathematics/wxmaxima: bump to 19.08.1
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-19.08.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index a0860a7964ab..95d0557430af 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,2 +1,3 @@
DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad25516ea9b0b375daf02edac5518b113188290262bc431e8bfb4836fc1f731982a1c41c62871818e4d2cc68c96ccb31 SHA512 964de93edc5c46e98de3de405b1873fa0ed594d54f1ddc030377b023110261cb1e6b0b08dbf210551888bf890e28d16e9b1698768c93dde413d5e1918cbd234e
DIST wxmaxima-19.05.7.tar.gz 13832202 BLAKE2B 6afe37dfcefe3f1711cc1cc89e4c61071dff2d49c60742a6d64ece9fa029823f6e94e20eb69e6d6cd8ccad1f5f656670089d593752f4be4d179222f5f2090d53 SHA512 3a7caee5ab03eefd4d2811345678d7b74081b0a4315dcc7739dbf4d265d274bb47a93ace5980a30185a13f40c1c970a8e4ba444bdd64b8b9ebd3b9a263cc6c06
+DIST wxmaxima-19.08.1.tar.gz 15153254 BLAKE2B 1bd48735ab95b078b9f35d7be623c1a16da6764649254579a2c2252ff858adb05e9408a85e5ed84dba6f15f879db761472276a5da77fa15e1c1823c678160aa3 SHA512 07f650144b8acd8295a45411185805185078f5236b67b33dac0f12308fc3b7522a6a46dfd2df35397c1d2fd5a357fb8d12473be4af576fcf09bda1e34352ae68
diff --git a/sci-mathematics/wxmaxima/wxmaxima-19.08.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-19.08.1.ebuild
new file mode 100644
index 000000000000..6e3b401b1d7f
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-19.08.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg-utils gnome2-utils
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/${1}.po || die "rm ${1}.po failed"
+ }
+ l10n_find_plocales_changes "${S}"/locales '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/wxmaxima.hhp /usr/share/doc/${PF}/wxmaxima_tr.hhp
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}