summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2015-09-13 18:12:43 +0600
committerAndrey Grozin <grozin@gentoo.org>2015-09-13 18:12:43 +0600
commitb83109ad0a10cd6f28c31d6cfe5ab220acbeb5a7 (patch)
tree9308e5af4f994c961c3a546a085f57d36fd3199a /sci-mathematics/wxmaxima
parentxfce-base/xfce4-settings: fix HDMI power cycling bug (diff)
downloadgentoo-b83109ad0a10cd6f28c31d6cfe5ab220acbeb5a7.tar.gz
gentoo-b83109ad0a10cd6f28c31d6cfe5ab220acbeb5a7.tar.bz2
gentoo-b83109ad0a10cd6f28c31d6cfe5ab220acbeb5a7.zip
sci-mathematics/wxmaxima: bump to 15.08.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-15.08.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index de7dad80c821..3b20c8db50df 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxMaxima-13.04.2.tar.gz 1652680 SHA256 29352db75dd3ff27393ab0971543fd0b3c3a
DIST wxmaxima-15.04.0.tar.gz 4990313 SHA256 c178067a2f75d91dd378f88b4d0f87af6b2705ca32bea509d63e7347b2a1d21e SHA512 1a899259698da38f97a1859ba0526406cbc654a130dc1d18e01cf248ac4d7292c82cb00dd92ce2fac2c3cfc002788fdef0a6a4f95eca54b9096efc73c6aa45b7 WHIRLPOOL 225456c073b1aa87d2e599b9c63244ff7c97378fb6b5a60fcb8730655d193a0f032b27a1264e12eefb4abf08389f2337a11c380b6d89af2de9a4fb6e14f614dc
DIST wxmaxima-15.08.1-missing.tar.bz2 14699 SHA256 62a84bf32e61d39f66787a7fb2cdbf67f322ddee2d7734c23650739476e97b17 SHA512 de64163643652a288fd6f65076df94074a28895a13ae8766a1913e12833d3dbb1ae4bbdbcd6a69221e5bde7000b93e3a86a223b1320d25581d32c61ea6ab3b98 WHIRLPOOL e96dac6ffd227597721a7e8fa200d99422e722ec5d3c1733c29904fdf1f6e2bae2ba1a2c8e98e217e7a089c5857c1ccf5d10950bd98cdbde0dfb19039a60262d
DIST wxmaxima-15.08.1.tar.gz 5577228 SHA256 82ad5314a88e53ff41dc431afb44ef1a47738686786e8cc8b4c48e0c147f4ffd SHA512 4ab7a8e992904e18e571b716d35f0d5286363b287853e3ebacc64e63df901fe192abdef16db8dc8defabb26a25f8f8956a7bad466862ee0d19d8846d4e3fec94 WHIRLPOOL 492c6ccf79640c9bfdb8d7aad283f5e0941bba8b38d037285712603112026e0feaf8873025657486df44ff718e559d9e690076e78f86e560f5d6b73ecd096ad9
+DIST wxmaxima-15.08.2.tar.gz 5592673 SHA256 7ad3f018e42d15d06bee5af10053edb72e441c1d1feee318dc6eb927db6a26c5 SHA512 a537c49477f54df4fd9e4e42a5e0d0d740f1ede817d807a98b7cec877a3ad77b2be0a61ae487a7fa5beb193b112eca163b8873292ecab5acf118d58a91e91af6 WHIRLPOOL a4df36704bbd33f841ddf3b9651662a092708850cdc637e6f6bfabc195c1e7e34dd66e14d92ee1cba69f3810bc74a4295837709d38bf6d6ce83b81d7776a3b9a
diff --git a/sci-mathematics/wxmaxima/wxmaxima-15.08.2.ebuild b/sci-mathematics/wxmaxima/wxmaxima-15.08.2.ebuild
new file mode 100644
index 000000000000..912f067ee735
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-15.08.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ local i
+
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in test/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Dirstructure.cpp src/Dirstructure.h \
+ || die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+ default
+ doicon -s 128 data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}