summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2017-01-02 11:18:51 +1100
committerMark Wright <gienah@gentoo.org>2017-01-02 11:20:08 +1100
commite1bee0588417636345663574e7c1ef127abbebe6 (patch)
tree0531ba68e6da9a2bda0cc307f9c92fff34461be2 /sci-mathematics/z3/files
parentnet-dns/libidn2: Version bump. (diff)
downloadgentoo-e1bee0588417636345663574e7c1ef127abbebe6.tar.gz
gentoo-e1bee0588417636345663574e7c1ef127abbebe6.tar.bz2
gentoo-e1bee0588417636345663574e7c1ef127abbebe6.zip
sci-mathematics/z3: Thanks to Yichao Zhou, jlec and slyfox for development
on the z3 ebuilds. Thanks to David E. Narv?ez for reporting and patching. Gentoo-bug: 602498, 602600 Package-Manager: portage-2.3.3
Diffstat (limited to 'sci-mathematics/z3/files')
-rw-r--r--sci-mathematics/z3/files/z3-4.1.2-configure.patch76
-rw-r--r--sci-mathematics/z3/files/z3-4.4.1-gcc-6.patch18
2 files changed, 94 insertions, 0 deletions
diff --git a/sci-mathematics/z3/files/z3-4.1.2-configure.patch b/sci-mathematics/z3/files/z3-4.1.2-configure.patch
new file mode 100644
index 000000000000..08ace2b697d9
--- /dev/null
+++ b/sci-mathematics/z3/files/z3-4.1.2-configure.patch
@@ -0,0 +1,76 @@
+--- z3-orig/configure.in 2012-10-04 16:41:04.000000000 +1000
++++ z3/configure.in 2012-10-18 15:56:49.895967069 +1100
+@@ -22,20 +22,29 @@
+
+ host_os=`uname -s`
+
++AC_ARG_ENABLE([static],
++[ --disable-static disable static],
++[static=${enableval}], [static=yes])
++
++if test "$static" = "yes"; then
++ STATIC_FLAGS=-static
++else
++ STATIC_FLAGS=
++fi
++
+ AS_IF([test "$host_os" = "Darwin"], [
+ PLATFORM=osx
+ SO_EXT=dylib
+- SLIBFLAGS="-dynamiclib -fopenmp"
++ LDFLAGS="${LDFLAGS}"
++ SLIBFLAGS="${LDFLAGS} -dynamiclib -fopenmp"
+ COMP_VERSIONS="-compatibility_version \$(Z3_VERSION) -current_version \$(Z3_VERSION)"
+- STATIC_FLAGS=
+ CPPFLAGS+=" -mmacosx-version-min=10.4"
+ ], [test "$host_os" = "Linux"], [
+ PLATFORM=linux
+- SO_EXT=so
+- LDFLAGS=-lrt
+- SLIBFLAGS="-shared -fopenmp"
++ SO_EXT=so.1.0
++ LDFLAGS="${LDFLAGS} -lrt"
++ SLIBFLAGS="${LDFLAGS} -shared -fopenmp"
+ COMP_VERSIONS=
+- STATIC_FLAGS=-static
+ ], [
+ AC_MSG_ERROR([Unknown host platform: $host_os])
+ ])
+@@ -88,15 +97,17 @@
+ AC_CHECK_LIB(gmp, __gmpz_cmp, LIBS="-lgmp $LIBS", AC_MSG_ERROR([GMP library not found]))
+ dnl Look for libgmp.a at /usr/local/lib and /usr/lib
+ dnl TODO: make the following test more robust...
+- if test -e /usr/local/lib/libgmp.a; then
+- GMP_STATIC_LIB="/usr/local/lib/libgmp.a"
+- else if test -e /usr/lib/libgmp.a; then
+- GMP_STATIC_LIB="/usr/lib/libgmp.a"
+- else if test -e /usr/lib/libgmp.dll.a; then
+- GMP_STATIC_LIB="/usr/lib/libgmp.dll.a"
+- else
+- AC_MSG_ERROR([Failed to find libgmp.a])
+- fi fi fi
++ if test "$static" = "yes"; then
++ if test -e /usr/local/lib/libgmp.a; then
++ GMP_STATIC_LIB="/usr/local/lib/libgmp.a"
++ else if test -e /usr/lib/libgmp.a; then
++ GMP_STATIC_LIB="/usr/lib/libgmp.a"
++ else if test -e /usr/lib/libgmp.dll.a; then
++ GMP_STATIC_LIB="/usr/lib/libgmp.dll.a"
++ else
++ AC_MSG_ERROR([Failed to find libgmp.a])
++ fi fi fi
++ fi
+ fi
+
+ AC_PROG_CXXCPP
+--- z3-orig/Makefile.in 2012-10-04 16:41:02.000000000 +1000
++++ z3/Makefile.in 2012-10-18 15:25:00.716162723 +1100
+@@ -175,7 +175,7 @@
+
+ $(BIN_DIR)/lib$(Z3).@SO_EXT@: $(OBJ_DIR) $(BIN_DIR) $(LIB_OBJS)
+ @mkdir -p $(BIN_DIR)
+- $(CXX) -o $(BIN_DIR)/lib$(Z3).@SO_EXT@ $(LIB_OBJS) $(LIBFLAGS) $(LIBS) @COMP_VERSIONS@
++ $(CXX) -Wl,-soname=lib$(Z3).@SO_EXT@ -o $(BIN_DIR)/lib$(Z3).@SO_EXT@ $(LIB_OBJS) $(LIBFLAGS) $(LIBS) @COMP_VERSIONS@
+
+ $(BIN_DIR)/lib$(Z3).a: $(OBJ_DIR) $(BIN_DIR) $(LIB_OBJS)
+ @mkdir -p $(BIN_DIR)
diff --git a/sci-mathematics/z3/files/z3-4.4.1-gcc-6.patch b/sci-mathematics/z3/files/z3-4.4.1-gcc-6.patch
new file mode 100644
index 000000000000..2dc0ddd12f26
--- /dev/null
+++ b/sci-mathematics/z3/files/z3-4.4.1-gcc-6.patch
@@ -0,0 +1,18 @@
+diff --git a/src/util/debug.cpp b/src/util/debug.cpp
+index 54c67fe..66676c6 100644
+--- a/src/util/debug.cpp
++++ b/src/util/debug.cpp
+@@ -78,3 +78,3 @@ void invoke_gdb() {
+ char result;
+- bool ok = (std::cin >> result);
++ bool ok = bool(std::cin >> result);
+ if (!ok) exit(ERR_INTERNAL_FATAL); // happens if std::cin is eof or unattached.
+diff --git a/src/util/mpz.cpp b/src/util/mpz.cpp
+index 8559279..7dca14b 100644
+--- a/src/util/mpz.cpp
++++ b/src/util/mpz.cpp
+@@ -136,3 +136,3 @@ mpz_manager<SYNCH>::mpz_manager():
+ mpz one(1);
+- set(m_two64, UINT64_MAX);
++ set(m_two64, (uint64)UINT64_MAX);
+ add(m_two64, one, m_two64);