summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-01 08:12:54 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-01 10:15:04 +0200
commit9e8d8756875ac679ca843350a5701d2dec5054e1 (patch)
tree733da70197feef0c8bba72ba52f844e2bebc239a /sci-mathematics/z3
parentsys-devel/distcc: stable 3.3.2-r5 for sparc, bug #679912 (diff)
downloadgentoo-9e8d8756875ac679ca843350a5701d2dec5054e1.tar.gz
gentoo-9e8d8756875ac679ca843350a5701d2dec5054e1.tar.bz2
gentoo-9e8d8756875ac679ca843350a5701d2dec5054e1.zip
sci-mathematics/z3: Bump to 4.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest1
-rw-r--r--sci-mathematics/z3/z3-4.8.5.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 8fa3186e1cc2..1f4aa04fbb42 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,4 @@
+DIST Z3-4.8.5.tar.gz 4177051 BLAKE2B f8c4be9dbab2d5cf6fdb0bd8e9e1648f8ac29bc8ca9241b3ef29699400b383f09601149d50899d6ca828abadacb71161af1524df6d1ed45d7fd95c4a49c0d3df SHA512 ca36e1a0332bd473a64f41dfdb31656fb3486178473e4fd4934dccce109a84c9686c08f94998df74bacb588eb12ea5db25dc17a564ee76f82fd2559349697309
DIST z3-4.4.1.tar.gz 3347371 BLAKE2B 57f090b891618613c4647a89620d12f2ac05ea110268e63b343594f53fa2cc7aa347781001e2778ea7dc1ce475c964ddeced7a82c304b4be706ad164fd17a285 SHA512 76991a24f47f2b53ceb8d7a9a6be19913c57994ffb6cf6acfe30f61b2e73959cf02a99f656053594fccb5aaf4d1f44b3ae7e51f1c8953b213d738ceeeaea74f8
DIST z3-4.5.0.tar.gz 3573695 BLAKE2B 285cc4d1f998d61ddb0b854044b7c79c1bb4cccf51bbdcba7c4a45698d74d9591f84d0aa74c5ef7c8aea2c6539ac987f29e326b44037e954108df67644dff594 SHA512 1ebc2c908d90b6b879f1e819c864ff894613276af47a440f27cf94968c195656952434754c3eb20f4bdbdd8497d227d22e1b4821c0d320b11052b5648d9e2dc7
DIST z3-4.8.4.tar.gz 4117081 BLAKE2B 6912defbae0e5444c451c4d7c6fb5d51167a1ae166257c7bfc53044ce7e9b9c4bd9824986c2ae1e6abfd6fef495234c9bea60078f8db2c1faaae11f34d666831 SHA512 4660ba6ab33a6345b2e8396c332d4afcfc73eda66ceb2595a39f152df4d62a9ea0f349b0f9212389ba84ecba6bdae6ad9b62b376ba44dc4d9c74f80d7a818bf4
diff --git a/sci-mathematics/z3/z3-4.8.5.ebuild b/sci-mathematics/z3/z3-4.8.5.ebuild
new file mode 100644
index 000000000000..7b359b0b167f
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.5.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P^}.tar.gz"
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc examples gmp isabelle java openmp python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ java? ( >=virtual/jdk-1.8 )"
+
+S=${WORKDIR}/${PN}-${P^}
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+pkg_setup() {
+ python_setup
+
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if use openmp && ! tc-has-openmp; then
+ ewarn "Please use an openmp compatible compiler"
+ ewarn "like >gcc-4.2 with USE=openmp"
+ die "Openmp support missing in compiler"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DUSE_LIB_GMP=$(usex gmp)
+ -DUSE_OPENMP=$(usex openmp)
+ -DENABLE_EXAMPLE_TARGETS=OFF
+ -DBUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DBUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DBUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT%/}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT%/}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT%/}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT%/}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT%/}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}