summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-08-11 14:15:53 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-08-11 14:15:53 +0700
commit0858ca1185750b64ebeeda1e16046b58eb5b69e7 (patch)
tree80d4508fe7098c965b935a23ce11e0ca88a44200 /sci-mathematics
parentdev-tex/rubber: stable 1.5.1 for ppc (diff)
downloadgentoo-0858ca1185750b64ebeeda1e16046b58eb5b69e7.tar.gz
gentoo-0858ca1185750b64ebeeda1e16046b58eb5b69e7.tar.bz2
gentoo-0858ca1185750b64ebeeda1e16046b58eb5b69e7.zip
sci-mathematics/wxmaxima: bump tp 20.07.0
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-20.07.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 101c442be4ce..15701a79b533 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -4,3 +4,4 @@ DIST wxmaxima-20.01.3.tar.gz 14221966 BLAKE2B cdaf62f5456446fe6edf1247323faa9f0a
DIST wxmaxima-20.02.4.tar.gz 15242422 BLAKE2B ea9dc613fa94d046a9d461c56a9d1564001f4fa28d90a553040e85b7dd442df025521dd9501257d12c808a2e9285b7f34b04c9f10d4ce658bc6d423055c9fbd7 SHA512 d5eb0e09de55c3e6ebafeaa95957ca8bbdacac9ec1d99f6041fa99b7fa59364b3228336675f9bffa71b879b17268b80c695f16c9259bee6d5cab9ef7ed86294b
DIST wxmaxima-20.04.0.tar.gz 15313618 BLAKE2B 04a9544aeb1a7084250696fad99c51be21bf0b119581cebdf62b8dece3034ebcc1469b9d07576bfed8d72efe77ce6db47b5a29c4185a5e85114b552d3385caf9 SHA512 8caf9effa0167c3307eff4a6895a3b19b41aab37f845e4cdc139f3cdd03d9a061adc9ea4ad8ca7e0f28d83faf34d15f828f03c86d05ad7d83f0e28aee82aba70
DIST wxmaxima-20.06.6.tar.gz 15627532 BLAKE2B b445cd0195561ec55d4f7c750eb2f44386267fa153638faf0d90b084e2c43d6d2cec5160011e2b0a6cadd662c31ca63f72df80328aef37234e1e5dfce9ee1f64 SHA512 65b4f93f8baf3c1b93ac1cac21b0a531e3d5fbf219540a0db4f6f66744909e3e787765ba1eb387823805df7201e6fa08bca165cdea2e0acb2687261fbd3cb269
+DIST wxmaxima-20.07.0.tar.gz 15723971 BLAKE2B cdec59e8ca17d0f4577a316a68e90795424d3d31829130e1854d908d76e54c02b125d20ce3a41ad5b4b06d57d918156bbbce7dead114b05daade34845d045124 SHA512 7272df5314ac79248154ee899397361da0570a6188ddc464b0479d2d6ac556ddf3941cf1ac17c9e6642e77d79a8458b902e70513dfdea15bc6a6d36d76b0bec2
diff --git a/sci-mathematics/wxmaxima/wxmaxima-20.07.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-20.07.0.ebuild
new file mode 100644
index 000000000000..9a2b704c52cf
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-20.07.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f "${S}"/locales/manual/${1}.po
+ rm -f "${S}"/locales/wxwin/${1}.po
+ rm -f "${S}"/info/${PN}.${1}.md
+ rm -f "${S}"/info/${PN}.${1}.html
+ }
+ l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake-utils_src_install
+}