summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2019-09-23 14:37:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-23 16:37:32 +0300
commit38ad2c47e1945f24d061d888a2384b76013fbaf1 (patch)
treedea732d1b2fc740d4aa8ae91bbb720929af8fe80 /sci-mathematics
parentmedia-fonts/cascadia-code: New ebuild (diff)
downloadgentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.tar.gz
gentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.tar.bz2
gentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.zip
sci-mathematics/gimps: version bump to version 29.8b6
Also bump to EAPI-7 Closes: https://bugs.gentoo.org/694962 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-29.8.6.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 57332f72fc0f..6c175e96dd97 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -3,3 +3,5 @@ DIST p95v2810.linux64.tar.gz 5707219 BLAKE2B 1ad26aa2fba4d7f4727bcd2dfe010d2b5b7
DIST p95v294b7.linux32.tar.gz 5455201 BLAKE2B 2d542c06fb490f6619884be3cd510fb77e130184d2b7d3bb44fd375fcd7c95e38ef4cf80ed01079c9f395d6e8a526930a07357f20e14277beba4e232f4e2ca27 SHA512 21ee6a8f0a4482bdb22d80093b24a8b9d7e091577628dc797ad01d3a0ab98e946814c70a6313e2624fffa6658454707f88d24608e107048fc6361d15aa5a7fbe
DIST p95v294b7.linux64.tar.gz 6244730 BLAKE2B ca5d0aad96e9bd5fb1bcb232435a26b7d8c2b9d869a6dc638d883fb892013df7a823abb0dae4545c2191b5f39b9cd29ee83400f452fbe63255f2dca899ad6bce SHA512 0579ea9ca1977884c8c50f8c8655b0fef1d5e2b456adca23d6d93542734727f265dc8f784c27fc9510c89afeec7386d4a9a9e9b5d691a97fed8189bef5577b3d
DIST p95v294b8.linux64.tar.gz 6244091 BLAKE2B ec02f582296f8959765f97526646f2f4a679a2b61d3c8e8efc971bf765c7f3b5cd4a9e2667661bcc6b0a3a088d095671af9b1f371f0e671de495935d582bf8e7 SHA512 bec8ce2081e9e349317441bbaa724e5d21ddfa1e328ccb6a17af796d41b201d96b2835fc2afcd68e350b22213225812cafdfca7973a7cd2071c1460188b3245d
+DIST p95v298b6.linux32.tar.gz 5696871 BLAKE2B e2c68c4dac1e4cfbc2e44542665326d33a7929585928ca720569b918f5286c97b93acc45c03d0514cadb29e87e5c6ca103e69953417df8405e36998c5768896b SHA512 6f82973237c59cd548fe7bfc08c51a62cc7ac4e98a8539e5dfbc23eec21fb6f46e1534dc834852557af61fa1a6fc9b634d9117d85fce37f8f6f9189fb724518b
+DIST p95v298b6.linux64.tar.gz 7032597 BLAKE2B de4de01d68caba4530d5adca165bfaa28cdb7e276b44355b200245cac6bab80bc05885a994c06331c2f66bdcd236c8bdb6cc8206ca40fb583bce6dc98eced7b1 SHA512 cb0ea195f4167e22bfdeef02872205a40ccd4d110abc9c354a413284db9aef1dbf9888ecdc3f09262e0d1033c0e4bed1f23d4d966fb58c437673a81095252bd1
diff --git a/sci-mathematics/gimps/gimps-29.8.6.ebuild b/sci-mathematics/gimps/gimps-29.8.6.ebuild
new file mode 100644
index 000000000000..ead2bcedc1c0
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-29.8.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils systemd readme.gentoo-r1
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}