summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-12 08:38:20 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-12 08:46:39 +0200
commit5162aec5c90b9cbcbade84a5136193a276d0be24 (patch)
tree95cdbd11765b5bd71096ef059b01547fae0afa30 /sci-mathematics
parentdev-util/bcc: Revbump to 0.9.0-r1, add dep on >=linux-headers-4.18 (diff)
downloadgentoo-5162aec5c90b9cbcbade84a5136193a276d0be24.tar.gz
gentoo-5162aec5c90b9cbcbade84a5136193a276d0be24.tar.bz2
gentoo-5162aec5c90b9cbcbade84a5136193a276d0be24.zip
sci-mathematics/genius: bump to 1.0.23
Intentionally not bumping to 1.0.24, as that mainly just bundles vte:0, and we don't need it just hiding as a copy, at least not until we still have to have vte:0 packages anyways. Other changes: * Remove long unnecessary libgnome*, libglade and popt rdeps * Remove gone rarian and gnome-doc-utils build deps * Depend on minimum versions required by configure.ac * Fix LICENSE to GPL3 _or later_ * Depend on virtual/yacc instead of local ORing of providers * gettext shouldn't be optional, and it is required by gtk+ anyway, and it's build time for translations anyway (libintl at runtime) * Remove gtk-update-icon-cache explicit dep - other packages don't add their own dep, but rely on gtk+ pulling it in, as that's what will actually use the cache. Do the same here Unfortunately QA warns about unrecognized --disable-scrollkeeper configure passing, but nothing worth doing about here - upstream has commented that stuff out with "#" comments in configure.ac, instead of "dnl" comments, thus it appears in configure and gnome2.eclass greps finds it and passes the argument. Closes: https://bugs.gentoo.org/605792 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/genius/Manifest1
-rw-r--r--sci-mathematics/genius/genius-1.0.23.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
index ac41674e7f76..b530a96a482f 100644
--- a/sci-mathematics/genius/Manifest
+++ b/sci-mathematics/genius/Manifest
@@ -1,2 +1,3 @@
DIST genius-1.0.21.tar.xz 2539784 BLAKE2B c4b6451c422c5f5a6a41d8af9ee003f69c4d813202eedba8eccabdcb2eb2405df552487e11f4ebd546968a04b2e6da2244452871d58fcef68d68105415f6ef98 SHA512 d4f5e80e1cc6216d7f460f7de86d232566eeb30fec90b93b2e6ccb8d2d0c14aaadf9b969c9a4f940a036e246f085edd02298c769504b620d2eb97ef2a3a852da
+DIST genius-1.0.23.tar.xz 2910332 BLAKE2B 8c9822737dfd0b445092c6b96376249093f3cfece4f0b98cb1bf62e9066336875fc014798b301686a9ffcaf5e37c1f324771c5b9e86c1578455874964427cca6 SHA512 8c64235d22734a7653468d39500ebbaa38b0ba7c25e292b4e96ddf825082584bf8c70e7ddc463b685ea01d51d3e08233b4e0cf8816a9a0e3357badb90d8e43c7
DIST genius-reference.pdf 1024944 BLAKE2B e0058fbd266a4ed4bf29306520ac64b7ff9a970fa79b5132f5556b61a97dd985fe916c888d0d5a678528ef231a9c66310dc2affe01491c7848451b3d54f58274 SHA512 04af3870104d2320b1d4b345d74d713a0dfcdf8a228002506508f437659b3ef6037ead0b1f6b37cc335692150750b58c4007fdaaddd9540233474ccd10dac285
diff --git a/sci-mathematics/genius/genius-1.0.23.ebuild b/sci-mathematics/genius/genius-1.0.23.ebuild
new file mode 100644
index 000000000000..ee3c65d94550
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.23.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="https://www.jirka.org/genius.html"
+SRC_URI="${SRC_URI}
+ doc? ( https://www.jirka.org/${PN}-reference.pdf )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ gnome? (
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/vte-0.26.0:0 )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/yacc
+ sys-devel/flex
+" # eautoreconf needs autoconf-archive
+
+src_configure() {
+ # Unrecognized --disable-scrollkeeper warning comes from gnome2.eclass adding it based on grep, but upstream has them commented out in .ac with "#" instead of "dnl"
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ --enable-nls \
+ --disable-extra-gcc-optimization \
+ --disable-static
+}
+
+src_install() {
+ use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
+ gnome2_src_install
+}