summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2016-05-03 08:59:40 +1000
committerMark Wright <gienah@gentoo.org>2016-05-03 09:00:39 +1000
commit595225ee11a3f1228d45e112b757e6beda119c78 (patch)
tree6ce207007efdc2b98119d980bfb8c94db8f6d4e2 /sci-mathematics
parentsys-kernel/git-sources: Linux patch 4.6_rc6 (diff)
downloadgentoo-595225ee11a3f1228d45e112b757e6beda119c78.tar.gz
gentoo-595225ee11a3f1228d45e112b757e6beda119c78.tar.bz2
gentoo-595225ee11a3f1228d45e112b757e6beda119c78.zip
sci-mathematics/octave: Fix bug 554226, thanks to Helmut Jarausch for reporting.
Thanks to Patric Schmitz for helping. The patch from upstream is in versions after 4.0. Gentoo-bug: 554226 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/files/octave-4.0.0-texinfo.patch63
-rw-r--r--sci-mathematics/octave/octave-4.0.0-r1.ebuild5
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/octave/files/octave-4.0.0-texinfo.patch b/sci-mathematics/octave/files/octave-4.0.0-texinfo.patch
new file mode 100644
index 000000000000..d94e75153366
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.0.0-texinfo.patch
@@ -0,0 +1,63 @@
+diff -r 3300cb76cccd -r 2ec049e50ed8 libinterp/corefcn/utils.cc
+--- a/libinterp/corefcn/utils.cc Tue Jul 07 19:09:35 2015 -0700
++++ b/libinterp/corefcn/utils.cc Thu Jul 09 21:44:09 2015 -0400
+@@ -1379,7 +1379,7 @@
+ \n\
+ Implementation Note: Strings are first converted to double values before the\n\
+ checks for valid indices are made. Unless a string contains the NULL\n\
+-character @nospell{\"\\0\"}, it will always be a valid index.\n\
++character @nospell{\"@xbackslashchar{}0\"}, it will always be a valid index.\n\
+ @end deftypefn")
+ {
+ octave_value retval;
+diff -r 3300cb76cccd -r 2ec049e50ed8 scripts/io/beep.m
+--- a/scripts/io/beep.m Tue Jul 07 19:09:35 2015 -0700
++++ b/scripts/io/beep.m Thu Jul 09 21:44:09 2015 -0400
+@@ -20,9 +20,9 @@
+ ## @deftypefn {Function File} {} beep ()
+ ## Produce a beep from the speaker (or visual bell).
+ ##
+-## This function sends the alarm character @qcode{"\a"} to the terminal.
+-## Depending on the user's configuration this may produce an audible beep,
+-## a visual bell, or nothing at all.
++## This function sends the alarm character @qcode{"@xbackslashchar{}a"} to
++## the terminal. Depending on the user's configuration this may produce an
++## audible beep, a visual bell, or nothing at all.
+ ## @seealso{puts, fputs, printf, fprintf}
+ ## @end deftypefn
+
+diff -r 2ec049e50ed8 -r 45d7be391982 doc/Makefile.am
+--- a/doc/Makefile.am Thu Jul 09 21:44:09 2015 -0400
++++ b/doc/Makefile.am Thu Jul 09 21:45:26 2015 -0400
+@@ -26,7 +26,6 @@
+
+ EXTRA_DIST = \
+ Makefile.am \
+- texinfo.tex \
+ texmf.cnf
+
+ SUBDIRS = doxyhtml interpreter liboctave refcard
+diff -r 2ec049e50ed8 -r 45d7be391982 doc/interpreter/Makefile.am
+--- a/doc/interpreter/Makefile.am Thu Jul 09 21:44:09 2015 -0400
++++ b/doc/interpreter/Makefile.am Thu Jul 09 21:45:26 2015 -0400
+@@ -20,8 +20,6 @@
+
+ include $(top_srcdir)/build-aux/common.mk
+
+-TEXINFO_TEX = ../texinfo.tex
+-
+ ## Leading PATH_SEPARATOR required due to weak parsing by dvips (12/04/09)
+ TEXINPUTS := "$(PATH_SEPARATOR)$(srcdir)$(PATH_SEPARATOR)$(TEXINPUTS)$(PATH_SEPARATOR)"
+ export TEXINPUTS
+diff -r 2ec049e50ed8 -r 45d7be391982 doc/liboctave/Makefile.am
+--- a/doc/liboctave/Makefile.am Thu Jul 09 21:44:09 2015 -0400
++++ b/doc/liboctave/Makefile.am Thu Jul 09 21:45:26 2015 -0400
+@@ -20,8 +20,6 @@
+
+ include $(top_srcdir)/build-aux/common.mk
+
+-TEXINFO_TEX = ../texinfo.tex
+-
+ info_TEXINFOS = liboctave.texi
+
+ liboctave_TEXINFOS = \
diff --git a/sci-mathematics/octave/octave-4.0.0-r1.ebuild b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
index 88a67af087ec..d19407f02c15 100644
--- a/sci-mathematics/octave/octave-4.0.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
@@ -100,6 +100,11 @@ src_prepare() {
-e 's@A-Za-z0-9@[:alnum:]@g' \
-e 's@A-Za-z@[:alpha:]@g' \
libinterp/mkbuiltins || die
+
+ # Fix bug 554226 - sci-mathematics/octave-4.0.0 fails because of a LaTeX error
+ epatch "${FILESDIR}"/${PN}-4.0.0-texinfo.patch
+ rm -f "${S}"/doc/texinfo.tex || die
+
autotools-utils_src_prepare
}