summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-19 18:50:33 +0000
committerSam James <sam@gentoo.org>2020-09-19 18:50:33 +0000
commit6587669ebc55bd9b9865677c5c16ba50cc31a0bf (patch)
treeef7747c77293def2e98de388b25ffe11f0032cb8 /sci-mathematics
parentsci-mathematics/num-utils: bump to debian's -15 patchset (diff)
downloadgentoo-6587669ebc55bd9b9865677c5c16ba50cc31a0bf.tar.gz
gentoo-6587669ebc55bd9b9865677c5c16ba50cc31a0bf.tar.bz2
gentoo-6587669ebc55bd9b9865677c5c16ba50cc31a0bf.zip
sci-mathematics/octave-epstk: port to EAPI 7
Closes: https://bugs.gentoo.org/740970 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild b/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild
index 9031c1f761fd..84af6b0bbb00 100644
--- a/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild
+++ b/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit eutils
DEB_PR=1
@@ -9,6 +10,7 @@ DESCRIPTION="Graphical output functions for Matlab and Octave"
HOMEPAGE="http://www.epstk.de/"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+S="${WORKDIR}"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
@@ -17,22 +19,27 @@ IUSE="doc"
RDEPEND="sci-mathematics/octave
app-text/ghostscript-gpl"
-DEPEND=""
-
-S="${WORKDIR}"
src_prepare() {
+ cd eps* || die
+
local p
- cd eps*
for p in $(cat "${WORKDIR}"/debian/patches/series); do
- epatch "${WORKDIR}"/debian/patches/${p}
+ eapply "${WORKDIR}"/debian/patches/${p}
done
+
+ default
}
src_install() {
insinto /usr/share/octave/site/m/${PN}
doins eps*/m/*
- use doc && dohtml -r eps*/doc/*
+
+ if use doc ; then
+ docinto html
+ dodoc -r eps*/doc/*
+ fi
+
insinto /etc
doins debian/epstk.conf
dodoc debian/README.Debian debian/changelog