summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-02-17 16:37:40 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-02-17 16:37:40 +0700
commit8f043383e3ee3e99f57f5bdc8a91b809274d385f (patch)
tree308fe0e3e08c849a8306add4dbc8ba4e2f43b391 /sci-mathematics
parentdev-python/reno: PEP517, py3.11, pypi.eclass (diff)
downloadgentoo-8f043383e3ee3e99f57f5bdc8a91b809274d385f.tar.gz
gentoo-8f043383e3ee3e99f57f5bdc8a91b809274d385f.tar.bz2
gentoo-8f043383e3ee3e99f57f5bdc8a91b809274d385f.zip
sci-mathematics/ginac: bump to 1.8.6
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/files/ginac-1.8.6-unicode.patch12
-rw-r--r--sci-mathematics/ginac/ginac-1.8.6.ebuild76
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index f7242284b3d1..13b9a4a18754 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1 +1,2 @@
DIST ginac-1.8.2.tar.bz2 1142428 BLAKE2B 9322ac30cd73c5290b68503a277c43751728a8d774655398038023d87796e35b8d98dff968a14faf162969877ef335b383adfb3fe695dda1357fb0208cba424a SHA512 fc471cdc12b3c2597e4deb65dcca83fc9050c8a2d07a19baf605b060efe9facc9b9ffe824676c8489bdebb6f125f1052f313394d95cc2a91c29b00a45cbc403a
+DIST ginac-1.8.6.tar.bz2 1152914 BLAKE2B 3d3d655cde0f5444fa01b0dde62a48d3c42b5a3b27e00d9608c56677fd031e639b7e4e6ac7c6cf68f807033cbe81432148d5525d76ad176b8dcd0d80aece07a1 SHA512 b10402d722e8216374dabdee9eba9e6de3b6afebd291a368697eb8efcd0eb8148237628bfb74713771c99977ccc46d972bacccaead3fcf35a1ab328744a7fb48
diff --git a/sci-mathematics/ginac/files/ginac-1.8.6-unicode.patch b/sci-mathematics/ginac/files/ginac-1.8.6-unicode.patch
new file mode 100644
index 000000000000..d7e4491f7434
--- /dev/null
+++ b/sci-mathematics/ginac/files/ginac-1.8.6-unicode.patch
@@ -0,0 +1,12 @@
+diff -r -U3 ginac-1.8.6.orig/ginac/numeric.cpp ginac-1.8.6/ginac/numeric.cpp
+--- ginac-1.8.6.orig/ginac/numeric.cpp 2023-02-08 06:02:38.000000000 +0700
++++ ginac-1.8.6/ginac/numeric.cpp 2023-02-17 16:13:45.137824611 +0700
+@@ -2139,7 +2139,7 @@
+ /** The Binomial coefficients. It computes the binomial coefficients. For
+ * integer n and k and positive n this is the number of ways of choosing k
+ * objects from n distinct objects. If n is a negative integer, the formula
+- * binomial(n,k) == (-1)^k*binomial(k-n-1,k) (if k≥0)
++ * binomial(n,k) == (-1)^k*binomial(k-n-1,k) (if k>=0)
+ * binomial(n,k) == (-1)^(n-k)*binomial(-k-1,n-k) (otherwise)
+ * is used to compute the result. */
+ const numeric binomial(const numeric &n, const numeric &k)
diff --git a/sci-mathematics/ginac/ginac-1.8.6.ebuild b/sci-mathematics/ginac/ginac-1.8.6.ebuild
new file mode 100644
index 000000000000..512edd467266
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.8.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-any-r1
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="https://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontsrecommended
+ media-gfx/transfig
+ dev-texlive/texlive-latexextra
+ virtual/texi2dvi
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.2-pkgconfig.patch "${FILESDIR}"/${PN}-1.8.6-unicode.patch )
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --disable-static
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ local -x VARTEXFONTS="${T}"/fonts
+ emake -C doc/reference html pdf
+ emake -C doc/tutorial ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ pushd doc >/dev/null || die
+ newdoc tutorial/ginac.pdf tutorial.pdf
+ newdoc reference/reference.pdf reference.pdf
+
+ docinto html/reference
+ dodoc -r reference/html_files/.
+
+ docinto html
+ newdoc tutorial/ginac.html tutorial.html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ pushd doc >/dev/null || die
+ docinto examples
+ dodoc examples/*.cpp examples/ginac-examples.*
+ docompress -x /usr/share/doc/${PF}/examples
+ popd >/dev/null || die
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}