summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2019-09-24 19:45:23 +1000
committerMark Wright <gienah@gentoo.org>2019-09-24 19:45:23 +1000
commit983a017561dee1f3d28f9e3cc71f40ffdccbec41 (patch)
treee570532c9754a1d2a2d2908274303107102e8689 /sci-mathematics
parentsys-kernel/vanilla-sources: Automated version bump to 3.16.74 - remove old. (diff)
downloadgentoo-983a017561dee1f3d28f9e3cc71f40ffdccbec41.tar.gz
gentoo-983a017561dee1f3d28f9e3cc71f40ffdccbec41.tar.bz2
gentoo-983a017561dee1f3d28f9e3cc71f40ffdccbec41.zip
sci-mathematics/coq: Bump to 8.9.1
Thanks to Han and Anton Kochkov for requesting the bump. Closes: https://bugs.gentoo.org/653864 Closes: https://bugs.gentoo.org/672038 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/Manifest1
-rw-r--r--sci-mathematics/coq/coq-8.9.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 7e3dbefa8fc1..758414ac5b91 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,2 +1,3 @@
DIST coq-8.6.1.tar.gz 5588811 BLAKE2B 1016e54ef9b42a8534add55ab057454fad35b3fe103ba877689489c7d9cf43d76c1fbee123801d91035d353a882120650f94c433d9ee1daa878b8c819609c949 SHA512 814ab76a06ca15f927081428da74add4bc67290199fa011853b9c68a00cdefaf813b10fbac18a434f4504fce8f2173eb544080bf6f50d62caa41bb8724b13083
DIST coq-8.6.tar.gz 5538848 BLAKE2B 025d6598a5155712662ce20a56804b75c236f1d1dc4ed81e779aaf2916d5cb525acfcbef9b5960fc5b8b44f2e2290c9f7e5c2d6e84726400a9888587ee29cd16 SHA512 9f5f4913fda8cf83683fec9398b42d4567207c3d4b52b4638d5e09a24ed25a43905fb57a9fac1bb9f9d681bd47f3560e1da74e79348b3a3fd93e2e8c686cebae
+DIST coq-8.9.1.tar.gz 6001970 BLAKE2B f65498e2485c59f4f95d2afeac35750ebf85b5af6db7c269a11635f2414df483d4cb159557060c9118de25f4922176f54d2e5c6f12174599371348341cb4d80f SHA512 66344f801b955d1b6daf3ab1d704551070c95cf9032ae74f15fb33f7ec313812b3e05c0ec277a2eb448e3fdfd9721df06d36612e2fb4928b6530d70147f1d983
diff --git a/sci-mathematics/coq/coq-8.9.1.ebuild b/sci-mathematics/coq/coq-8.9.1.ebuild
new file mode 100644
index 000000000000..a7de5198ee4c
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.9.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+# Note: RDEPEND will require dev-ml/num:= for >=dev-lang/ocaml-4.0.7
+RDEPEND="
+ >=dev-lang/ocaml-4.0.5:=[ocamlopt?]
+ dev-ml/camlp5:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[sourceview,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ -lablgtkdir ${ocaml_lib}/lablgtk2
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS CHANGES.md
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}