summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-13 21:50:27 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-13 21:52:18 +0100
commita7f6efd5ca806e141c760fccb31e3b5a9b0aeeac (patch)
treebd468c620664574c73f8691a584f0bd72ba9848b /sci-mathematics
parentsci-mathematics/z3: Enable python3 (diff)
downloadgentoo-a7f6efd5ca806e141c760fccb31e3b5a9b0aeeac.tar.gz
gentoo-a7f6efd5ca806e141c760fccb31e3b5a9b0aeeac.tar.bz2
gentoo-a7f6efd5ca806e141c760fccb31e3b5a9b0aeeac.zip
sci-mathematics/z3: Run tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/z3/z3-4.8.3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sci-mathematics/z3/z3-4.8.3.ebuild b/sci-mathematics/z3/z3-4.8.3.ebuild
index ea65ed84b8ac..7c82aaa652f3 100644
--- a/sci-mathematics/z3/z3-4.8.3.ebuild
+++ b/sci-mathematics/z3/z3-4.8.3.ebuild
@@ -53,6 +53,13 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ cmake-utils_src_make test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
src_install() {
local DOCS=( "README.md" "RELEASE_NOTES" )
cmake-utils_src_install