summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-13 04:24:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-13 04:40:23 +0200
commitad0442b9f6f83e7c0900d50fa08e2fe2165d3f66 (patch)
treec95c2b8f9c937c6ef257ebed5207f0b5bf7d75af /sci-mathematics
parentapp-containers/nerdctl: add 0.23.0 (diff)
downloadgentoo-ad0442b9f6f83e7c0900d50fa08e2fe2165d3f66.tar.gz
gentoo-ad0442b9f6f83e7c0900d50fa08e2fe2165d3f66.tar.bz2
gentoo-ad0442b9f6f83e7c0900d50fa08e2fe2165d3f66.zip
sci-mathematics/cadical: bump to 1.5.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cadical/Manifest1
-rw-r--r--sci-mathematics/cadical/cadical-1.5.3.ebuild35
-rw-r--r--sci-mathematics/cadical/files/cadical-configure.patch21
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index f3ef6cd607bc..d1c01c50a22c 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1 +1,2 @@
DIST cadical-1.5.2.tar.gz 596334 BLAKE2B 2e6c0f0602b807cf9ee5993aa627e074291b0128d19474d5431e01992d66b111773e593c14712338e9702f64e23eae6fdd937b5b86b2b9b3e08022dbbb199fd7 SHA512 1aab87bdaec938eb219f75f13bf2fcb031f47ac1f49b586f769aeececd1c33b166341bef3bc8713e62b4612a91c405db33e6d1b48e1074a3433d80e9ecb33fe2
+DIST cadical-1.5.3.tar.gz 596378 BLAKE2B 1ac27412745b0f24668ccf2ea1ff89e02c1e68137110bf9522a63ad82b14621d898d0bf873a651a24ccef9f502982f5e2d5b9c558ed0b1c5b7432c1a1459cb58 SHA512 bec811ab6a4c392506bdc391227d108476b5b5fae280b2d7d484429fe6d84e86206a054a1044cf68046ce183ecd7af3ec58f8be3ac27224fe37930cf43f08f3b
diff --git a/sci-mathematics/cadical/cadical-1.5.3.ebuild b/sci-mathematics/cadical/cadical-1.5.3.ebuild
new file mode 100644
index 000000000000..dac39982db2e
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
+ "${FILESDIR}"/${PN}-makefile.in-ar.patch
+)
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ einstalldocs
+}
diff --git a/sci-mathematics/cadical/files/cadical-configure.patch b/sci-mathematics/cadical/files/cadical-configure.patch
new file mode 100644
index 000000000000..c6135cb08664
--- /dev/null
+++ b/sci-mathematics/cadical/files/cadical-configure.patch
@@ -0,0 +1,21 @@
+Remove forced debugging or optimization flags.
+
+--- a/configure
++++ b/configure
+@@ -261,16 +261,6 @@ case x"$CXX" in
+ *) CXXFLAGS="${CXXFLAGS}-W";;
+ esac
+
+-if [ $debug = yes ]
+-then
+- CXXFLAGS="$CXXFLAGS -g"
+-else
+- case x"$CXX" in
+- x*g++*|x*clang++*) CXXFLAGS="$CXXFLAGS -O3";;
+- *) CXXFLAGS="$CXXFLAGS -O";;
+- esac
+-fi
+-
+ if [ $m32 = yes ]
+ then
+ case x"$CXX" in