summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-08 22:07:28 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-09 00:07:45 +0200
commitc13bca2bd6185c512eda1183e5befe1e27e421ad (patch)
treeb7abd8290150d48908b3cea3665876e07f177c91 /sci-mathematics
parentsci-mathematics/minisat: revbump (EAPI 2 -> 6) (diff)
downloadgentoo-c13bca2bd6185c512eda1183e5befe1e27e421ad.tar.gz
gentoo-c13bca2bd6185c512eda1183e5befe1e27e421ad.tar.bz2
gentoo-c13bca2bd6185c512eda1183e5befe1e27e421ad.zip
sci-mathematics/minisat: Removing EAPI 2 ebuilds
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2279 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/minisat/Manifest1
-rw-r--r--sci-mathematics/minisat/minisat-2.1.0.ebuild96
-rw-r--r--sci-mathematics/minisat/minisat-2.2.0-r3.ebuild93
3 files changed, 0 insertions, 190 deletions
diff --git a/sci-mathematics/minisat/Manifest b/sci-mathematics/minisat/Manifest
index f76d6525d8ea..12aa8412d0b2 100644
--- a/sci-mathematics/minisat/Manifest
+++ b/sci-mathematics/minisat/Manifest
@@ -1,3 +1,2 @@
DIST MiniSat.pdf 327416 SHA256 53197dbd783c924a2627d75e305706297988494265bd5e5ec873840e5d797ac4 SHA512 94e70c721740c0b7fd52621c7a5e43dd9207eed92e60a1c64ee63b541b9861d2580d14ba64c49c6c4f273ac028ded43bc944c71131e51693cdd7d1763af582f6 WHIRLPOOL a087d8929476fc33464d19432fc05a01797761f695b81c0aa6d35270731b00dabe2402ea2cfd705b49d5d6664a3cbd46bc60147d60934acdfc94a33066316185
DIST minisat-2.2.0.tar.gz 43879 SHA256 92957d851cdc3baddfe07b5fc80ed5a0237c489d0c52ae72f62844b3b46d7808 SHA512 cf79b05d43ebdc8fd8081899a1f853370de051cafe6e5b143eaff9827efc542b58062782a3ce2a3d1a03561a9ffd780c9cdc645bb50036eb61e80fa729136e64 WHIRLPOOL a5117e7bc81aeecb6fa34d8e2dea70b379d9e3463957e7029c80957ff3bcdd3107a99fb0dabfe59b57bfdb16ed51a0a4781c8dbf8e3f6f225ebd5035c1a9ff79
-DIST minisat2-070721.zip 48776 SHA256 ddc2ed421a538a349ddab58d3958076d73813925ff08361e6292583d3b87248e SHA512 2d3d1597cf0631e8f24ef1aa9be020971e9d0732197614f8cfaa47abe63354ba6e68ef31e554539006ba0dc501eadfca42de603c0e1c2dc1824f05197b6e63a1 WHIRLPOOL 05771824a138b136bd967287cf8d67848c42061c3b5a87a0f7348140aedc449bf79a118cd40647c241635cecfec65a868ed30b0b183f23d39bcf351fe1c520b1
diff --git a/sci-mathematics/minisat/minisat-2.1.0.ebuild b/sci-mathematics/minisat/minisat-2.1.0.ebuild
deleted file mode 100644
index 46b0736f5374..000000000000
--- a/sci-mathematics/minisat/minisat-2.1.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}2-070721"
-
-DESCRIPTION="Small yet efficient SAT solver with reference paper"
-HOMEPAGE="http://minisat.se/Main.html"
-SRC_URI="http://minisat.se/downloads/${MY_P}.zip
- doc? ( http://minisat.se/downloads/MiniSat.pdf )"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="MIT"
-
-IUSE="debug doc extended-solver"
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- if use debug; then
- myconf="d"
- myext="debug"
- else
- myconf="r"
- myext="release"
- fi
-
- if use extended-solver; then
- mydir="simp"
- else
- mydir="core"
- fi
-
- tc-export CXX
-
- if has_version ">=sci-mathematics/minisat-2.2.0" ; then
- elog ""
- elog "The minisat2 2.1 and 2.2 ABIs are not compatible and there"
- elog "is currently no slotting. Please mask it yourself (eg, in"
- elog "packages.mask) if you need to use the 2.1x version."
- elog ""
- epause 5
- fi
-}
-
-src_prepare() {
- sed -i \
- -e "s|-O3|${CFLAGS} ${LDFLAGS}|" \
- -e "s|@\$(CXX)|\$(CXX)|" \
- mtl/template.mk || die
-}
-
-src_compile() {
- export MROOT="${S}"
- emake -C ${mydir} "$myconf" || die
-
- if ! use debug; then
- LIB="${PN}" emake -C ${mydir} lib || die
- else
- LIB="${PN}" emake -C ${mydir} libd || die
- fi
-}
-
-src_install() {
- # somewhat brute-force, but so is the build setup...
-
- insinto /usr/include/${PN}2/mtl
- doins mtl/*.h || die
-
- insinto /usr/include/${PN}2/core
- doins core/Solver*.h || die
-
- insinto /usr/include/${PN}2/simp
- doins simp/Simp*.h || die
-
- if ! use debug; then
- newbin ${mydir}/${PN}_${myext} ${PN} || die
- dolib.a ${mydir}/lib${PN}.a || die
- else
- newbin ${mydir}/${PN}_${myext} ${PN} || die
- newlib.a ${mydir}/lib${PN}_${myext}.a lib${PN}.a || die
- fi
-
- dodoc README || die
- if use doc; then
- dodoc "${DISTDIR}"/MiniSat.pdf || die
- fi
-}
diff --git a/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild b/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild
deleted file mode 100644
index 029a36faab2c..000000000000
--- a/sci-mathematics/minisat/minisat-2.2.0-r3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Small yet efficient SAT solver with reference paper"
-HOMEPAGE="http://minisat.se/Main.html"
-SRC_URI="http://minisat.se/downloads/${P}.tar.gz
- doc? ( http://minisat.se/downloads/MiniSat.pdf )"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="MIT"
-
-IUSE="debug doc extended-solver"
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- if use debug; then
- myconf="d"
- myext="debug"
- else
- myconf="r"
- myext="release"
- fi
-
- if use extended-solver; then
- mydir="simp"
- else
- mydir="core"
- fi
- tc-export CXX
-
- if has_version "=sci-mathematics/minisat-2.1*" ; then
- elog ""
- elog "The minisat2 2.1 and 2.2 ABIs are not compatible and there"
- elog "is currently no slotting. Please mask it yourself (eg, in"
- elog "packages.mask) if you still need the older version."
- elog ""
- epause 5
- fi
-}
-
-src_prepare() {
- sed -e "s/\$(CXX) \$^/\$(CXX) \$(LDFLAGS) \$^/" \
- -i -e "s|-O3|${CFLAGS}|" mtl/template.mk || die
-}
-
-src_compile() {
- export MROOT="${S}"
- emake -C ${mydir} "$myconf" || die
- LIB="${PN}" emake -C ${mydir} lib"$myconf" || die
-}
-
-src_install() {
- # somewhat brute-force, but so is the build setup...
- fix_headers
-
- insinto /usr/include/${PN}2/mtl
- doins mtl/*.h || die
-
- insinto /usr/include/${PN}2/core
- doins core/Solver*.h || die
-
- insinto /usr/include/${PN}2/simp
- doins simp/Simp*.h || die
-
- insinto /usr/include/${PN}2/utils
- doins utils/*.h || die
-
- newbin ${mydir}/${PN}_${myext} ${PN} || die
- newlib.a ${mydir}/lib${PN}_${myext}.a lib${PN}.a || die
-
- dodoc README doc/ReleaseNotes-2.2.0.txt || die
- if use doc; then
- dodoc "${DISTDIR}"/MiniSat.pdf || die
- fi
-}
-
-fix_headers() {
- # need to fix the circular internal includes a bit for standard usage
- elog "Fixing header files..."
-
- patch -p0 < "${FILESDIR}"/${P}-header_fix.patch \
- || die "header patch failed..."
-}