summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-20 01:32:10 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-20 01:53:39 +0100
commitc7aee643a9472d7ea97c8e1266ed8102e3298535 (patch)
tree110f360f7896b483bed67a957222880e95c5bfd6 /sci-mathematics
parentsci-mathematics/stp: rename patches (diff)
downloadgentoo-c7aee643a9472d7ea97c8e1266ed8102e3298535.tar.gz
gentoo-c7aee643a9472d7ea97c8e1266ed8102e3298535.tar.bz2
gentoo-c7aee643a9472d7ea97c8e1266ed8102e3298535.zip
sci-mathematics/stp: patch - include cstdint
Closes: https://bugs.gentoo.org/895096 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/stp/files/stp-2.3.3-cstdint.patch11
-rw-r--r--sci-mathematics/stp/stp-2.3.3-r2.ebuild3
2 files changed, 14 insertions, 0 deletions
diff --git a/sci-mathematics/stp/files/stp-2.3.3-cstdint.patch b/sci-mathematics/stp/files/stp-2.3.3-cstdint.patch
new file mode 100644
index 000000000000..4c010848ee36
--- /dev/null
+++ b/sci-mathematics/stp/files/stp-2.3.3-cstdint.patch
@@ -0,0 +1,11 @@
+--- a/./include/stp/AST/ASTNode.h
++++ b/./include/stp/AST/ASTNode.h
+@@ -24,6 +24,8 @@ THE SOFTWARE.
+ #ifndef ASTNODE_H
+ #define ASTNODE_H
+
++#include <cstdint>
++
+ #include "stp/AST/NodeFactory/HashingNodeFactory.h"
+ #include "stp/Util/Attributes.h"
+ #include "ASTInternal.h"
diff --git a/sci-mathematics/stp/stp-2.3.3-r2.ebuild b/sci-mathematics/stp/stp-2.3.3-r2.ebuild
index f9142adbe6df..000e5bef36f9 100644
--- a/sci-mathematics/stp/stp-2.3.3-r2.ebuild
+++ b/sci-mathematics/stp/stp-2.3.3-r2.ebuild
@@ -42,9 +42,12 @@ BDEPEND="test? ( dev-python/lit )"
PATCHES=(
"${FILESDIR}"/${P}-CMakeLists.txt-fix_cflags.patch
+ "${FILESDIR}"/${P}-cstdint.patch
"${FILESDIR}"/${P}-stp.py-library_path.patch
)
+#include <cstdint>
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}