summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-29 15:45:17 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-29 16:35:33 -0500
commite50be8a41d664ed38d2903406bac8f3f28ffb695 (patch)
tree8a4373d2943c7b0cb74c4ea458bb286d1d0983a6 /sci-mathematics
parentdev-libs/gjs: Version bump to 1.64.2 (diff)
downloadgentoo-e50be8a41d664ed38d2903406bac8f3f28ffb695.tar.gz
gentoo-e50be8a41d664ed38d2903406bac8f3f28ffb695.tar.bz2
gentoo-e50be8a41d664ed38d2903406bac8f3f28ffb695.zip
sci-mathematics/petsc: version bump to 13.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/Manifest1
-rw-r--r--sci-mathematics/petsc/files/petsc-3.13.0-do_not_run_mpiexec.patch34
-rw-r--r--sci-mathematics/petsc/files/petsc-3.13.0-fix_sandbox_violation.patch18
-rw-r--r--sci-mathematics/petsc/files/petsc-3.13.0-make_hypre_configure.patch90
-rw-r--r--sci-mathematics/petsc/petsc-3.13.0.ebuild189
5 files changed, 332 insertions, 0 deletions
diff --git a/sci-mathematics/petsc/Manifest b/sci-mathematics/petsc/Manifest
index 35342d214c52..f7372ecf5e15 100644
--- a/sci-mathematics/petsc/Manifest
+++ b/sci-mathematics/petsc/Manifest
@@ -1,2 +1,3 @@
DIST petsc-3.11.3.tar.gz 33279017 BLAKE2B 870b8245e5e06d8538ea3ee1d01fa2cebade4a0bd79dfcf17d74e6201f41d21ca021e206744ece28847b434ece142a2789851b5514a8a1e3f82a8551288b695b SHA512 e545f69e87bc72950939ff3cec3e0ba225a5b3e7f1cb93b0fb6123194eb7240ac1d97ba397235d8ab872c653caab1427673124e5e1e706b796c0ae46ec1bcffa
DIST petsc-3.12.1.tar.gz 34592587 BLAKE2B b48056a1fe1d507338f7d145f5fceeab2b2f576470d8af90c9d7828de9b775daadf11198fecc46b5e48fcf1eb38addb366e3a908dab5c4ffaf7f9b71ff17b3d8 SHA512 df33170922c0b34136d2fd5bdc3c68a80d3a5873d66bfb03b2cea4a6456393c7181a8da673911b89ea0fcb51d5fd89b5b4c8b76ddb1df573180a92d029fbc1fb
+DIST petsc-3.13.0.tar.gz 35080264 BLAKE2B 0ac58e53751dbc6e053e3591cdf2363194e0cf7a493f252d879031e0135da16fa24e66974dd7bf07ce18558a75f8dd794e87f96590ad9e550d11edfeb462f727 SHA512 0590bb63d9c6dfd6ac03b1b88e5a8c11d42a0fd014084603d4d085060b126aa4341b4ec3a4d2b12146b971da327ccc7ede370e5633282bf44f269465aea32953
diff --git a/sci-mathematics/petsc/files/petsc-3.13.0-do_not_run_mpiexec.patch b/sci-mathematics/petsc/files/petsc-3.13.0-do_not_run_mpiexec.patch
new file mode 100644
index 000000000000..4c46658dec71
--- /dev/null
+++ b/sci-mathematics/petsc/files/petsc-3.13.0-do_not_run_mpiexec.patch
@@ -0,0 +1,34 @@
+diff --git a/config/BuildSystem/config/packages/MPI.py b/config/BuildSystem/config/packages/MPI.py
+index 7e424e71..ee502bd2 100644
+--- a/config/BuildSystem/config/packages/MPI.py
++++ b/config/BuildSystem/config/packages/MPI.py
+@@ -210,28 +210,11 @@ shared libraries and run with --known-mpi-shared-libraries=1')
+ raise RuntimeError('Could not locate MPIEXEC - please specify --with-mpiexec option')
+ # Support for spaces and () in executable names; also needs to handle optional arguments at the end
+ # TODO: This support for spaces and () should be moved to core BuildSystem
+- self.mpiexec = self.mpiexec.replace(' ', '\\ ').replace('(', '\\(').replace(')', '\\)').replace('\ -',' -')
+- if (hasattr(self, 'ompi_major_version') and int(self.ompi_major_version) >= 3):
+- (out, err, ret) = Configure.executeShellCommand(self.mpiexec+' -help all', checkCommand = noCheck, timeout = 60, log = self.log, threads = 1)
+- if out.find('--oversubscribe') >=0:
+- self.mpiexec = self.mpiexec + ' --oversubscribe'
++ self.mpiexec = self.mpiexec + ' --oversubscribe'
+
+ # using mpiexec environmental variables make sure mpiexec matches the MPI libraries and save the variables for testing in PetscInitialize()
+ # the variable HAVE_MPIEXEC_ENVIRONMENTAL_VARIABLE is not currently used. PetscInitialize() can check the existence of the environmental variable to
+ # determine if the program has been started with the correct mpiexec (will only be set for parallel runs so not clear how to check appropriately)
+- (out, err, ret) = Configure.executeShellCommand(self.mpiexec+' -n 1 printenv', checkCommand = noCheck, timeout = 60, threads = 1, log = self.log)
+- if ret:
+- self.logWrite('Unable to run '+self.mpiexec+' with option "-n 1 printenv"\nThis could be ok, some MPI implementations such as SGI produce a non-zero status with non-MPI programs\n'+out+err)
+- else:
+- if out.find('MPIR_CVAR_CH3') > -1:
+- if hasattr(self,'ompi_major_version'): raise RuntimeError("Your libraries are from OpenMPI but it appears your mpiexec is from MPICH");
+- self.addDefine('HAVE_MPIEXEC_ENVIRONMENTAL_VARIABLE', 'MPIR_CVAR_CH3')
+- elif out.find('MPIR_CVAR_CH3') > -1:
+- if hasattr(self,'ompi_major_version'): raise RuntimeError("Your libraries are from OpenMPI but it appears your mpiexec is from MPICH");
+- self.addDefine('HAVE_MPIEXEC_ENVIRONMENTAL_VARIABLE', 'MPICH')
+- elif out.find('OMPI_COMM_WORLD_SIZE') > -1:
+- if hasattr(self,'mpich_numversion'): raise RuntimeError("Your libraries are from MPICH but it appears your mpiexec is from OpenMPI");
+- self.addDefine('HAVE_MPIEXEC_ENVIRONMENTAL_VARIABLE', 'OMP')
+
+ self.addMakeMacro('MPIEXEC', self.mpiexec)
+ self.mpiexec = self.mpiexec + ' -n 1'
diff --git a/sci-mathematics/petsc/files/petsc-3.13.0-fix_sandbox_violation.patch b/sci-mathematics/petsc/files/petsc-3.13.0-fix_sandbox_violation.patch
new file mode 100644
index 000000000000..c0dfd53a0112
--- /dev/null
+++ b/sci-mathematics/petsc/files/petsc-3.13.0-fix_sandbox_violation.patch
@@ -0,0 +1,18 @@
+diff --git a/config/PETSc/options/installDir.py b/config/PETSc/options/installDir.py
+index 860faf0f..87898811 100755
+--- a/config/PETSc/options/installDir.py
++++ b/config/PETSc/options/installDir.py
+@@ -40,13 +40,6 @@ class Configure(config.base.Configure):
+ self.dir = os.path.abspath(os.path.expanduser(self.framework.argDB['prefix']))
+ self.petscDir = self.dir
+ self.petscArch = ''
+- try:
+- os.makedirs(os.path.join(self.dir,'PETScTestDirectory'))
+- os.rmdir(os.path.join(self.dir,'PETScTestDirectory'))
+- except Exception as e:
+- self.logPrint('Error trying to to test write permissions on directory '+str(e))
+- self.installSudoMessage = 'You do not have write permissions to the --prefix directory '+self.dir+'\nYou will be prompted for the sudo password for any external package installs'
+- self.installSudo = 'sudo '
+ else:
+ self.dir = os.path.abspath(os.path.join(self.petscdir.dir, self.arch.arch))
+ self.petscDir = self.petscdir.dir
diff --git a/sci-mathematics/petsc/files/petsc-3.13.0-make_hypre_configure.patch b/sci-mathematics/petsc/files/petsc-3.13.0-make_hypre_configure.patch
new file mode 100644
index 000000000000..1453fd519e81
--- /dev/null
+++ b/sci-mathematics/petsc/files/petsc-3.13.0-make_hypre_configure.patch
@@ -0,0 +1,90 @@
+diff --git a/config/BuildSystem/config/packages/hypre.py b/config/BuildSystem/config/packages/hypre.py
+index 4d915c31..1b05a1ee 100644
+--- a/config/BuildSystem/config/packages/hypre.py
++++ b/config/BuildSystem/config/packages/hypre.py
+@@ -5,10 +5,6 @@ class Configure(config.package.GNUPackage):
+ def __init__(self, framework):
+ config.package.GNUPackage.__init__(self, framework)
+ #self.version = '2.18.2'
+- self.minversion = '2.14'
+- self.versionname = 'HYPRE_RELEASE_VERSION'
+- self.versioninclude = 'HYPRE_config.h'
+- self.requiresversion = 1
+ #self.gitcommit = 'v'+self.version
+ self.gitcommit = '93baaa8c9' # v2.18.2+valgrind-fix
+ self.download = ['git://https://github.com/hypre-space/hypre','https://github.com/hypre-space/hypre/archive/'+self.gitcommit+'.tar.gz']
+diff --git a/include/petsc/private/petschypre.h b/include/petsc/private/petschypre.h
+index 81ca7136..b403e70e 100644
+--- a/include/petsc/private/petschypre.h
++++ b/include/petsc/private/petschypre.h
+@@ -6,12 +6,6 @@
+ #include <HYPRE_config.h>
+ #include <HYPRE_utilities.h>
+
+-/* from version 2.16 on, HYPRE_BigInt is 64 bit for 64bit installations
+- and 32 bit for 32bit installations -> not the best name for a variable */
+-#if PETSC_PKG_HYPRE_VERSION_LT(2,16,0)
+-typedef PetscInt HYPRE_BigInt;
+-#endif
+-
+ /*
+ With scalar type == real, HYPRE_Complex == PetscScalar;
+ With scalar type == complex, HYPRE_Complex is double __complex__ while PetscScalar may be std::complex<double>
+diff --git a/src/mat/impls/hypre/mhypre.c b/src/mat/impls/hypre/mhypre.c
+index 0f7470e6..cce3e2b0 100644
+--- a/src/mat/impls/hypre/mhypre.c
++++ b/src/mat/impls/hypre/mhypre.c
+@@ -15,10 +15,6 @@
+ #include <_hypre_parcsr_ls.h>
+ #include <_hypre_sstruct_ls.h>
+
+-#if PETSC_PKG_HYPRE_VERSION_LT(2,18,0)
+-#define hypre_ParCSRMatrixClone(A,B) hypre_ParCSRMatrixCompleteClone(A)
+-#endif
+-
+ static PetscErrorCode MatHYPRE_CreateFromMat(Mat,Mat_HYPRE*);
+ static PetscErrorCode MatHYPRE_IJMatrixPreallocate(Mat,Mat,HYPRE_IJMatrix);
+ static PetscErrorCode MatHYPRE_IJMatrixFastCopy_MPIAIJ(Mat,HYPRE_IJMatrix);
+@@ -63,7 +59,6 @@ static PetscErrorCode MatHYPRE_IJMatrixPreallocate(Mat A_d, Mat A_o, HYPRE_IJMat
+ nnz_o[i] = 0;
+ }
+ }
+-#if PETSC_PKG_HYPRE_VERSION_GE(2,16,0)
+ { /* If we don't do this, the columns of the matrix will be all zeros! */
+ hypre_AuxParCSRMatrix *aux_matrix;
+ aux_matrix = (hypre_AuxParCSRMatrix*)hypre_IJMatrixTranslator(ij);
+@@ -73,9 +68,6 @@ static PetscErrorCode MatHYPRE_IJMatrixPreallocate(Mat A_d, Mat A_o, HYPRE_IJMat
+ aux_matrix = (hypre_AuxParCSRMatrix*)hypre_IJMatrixTranslator(ij);
+ hypre_AuxParCSRMatrixNeedAux(aux_matrix) = 1;
+ }
+-#else
+- PetscStackCallStandard(HYPRE_IJMatrixSetDiagOffdSizes,(ij,nnz_d,nnz_o));
+-#endif
+ ierr = PetscFree(nnz_d);CHKERRQ(ierr);
+ ierr = PetscFree(nnz_o);CHKERRQ(ierr);
+ }
+@@ -233,11 +225,7 @@ static PetscErrorCode MatHYPRE_IJMatrixFastCopy_MPIAIJ(Mat A, HYPRE_IJMatrix ij)
+ /* need to shift the diag column indices (hdiag->j) back to global numbering since hypre is expecting this */
+ hjj = hdiag->j;
+ pjj = pdiag->j;
+-#if PETSC_PKG_HYPRE_VERSION_GE(2,16,0)
+ for (i=0; i<pdiag->nz; i++) hjj[i] = pjj[i];
+-#else
+- for (i=0; i<pdiag->nz; i++) hjj[i] = cstart + pjj[i];
+-#endif
+ ierr = PetscArraycpy(hdiag->data,pdiag->a,pdiag->nz);CHKERRQ(ierr);
+ if (sameint) {
+ ierr = PetscArraycpy(hoffd->i,poffd->i,pA->A->rmap->n + 1);CHKERRQ(ierr);
+@@ -247,12 +235,8 @@ static PetscErrorCode MatHYPRE_IJMatrixFastCopy_MPIAIJ(Mat A, HYPRE_IJMatrix ij)
+
+ /* need to move the offd column indices (hoffd->j) back to global numbering since hypre is expecting this
+ If we hacked a hypre a bit more we might be able to avoid this step */
+-#if PETSC_PKG_HYPRE_VERSION_GE(2,16,0)
+ PetscStackCallStandard(hypre_CSRMatrixBigInitialize,(hoffd));
+ jj = (PetscInt*) hoffd->big_j;
+-#else
+- jj = (PetscInt*) hoffd->j;
+-#endif
+ pjj = poffd->j;
+ for (i=0; i<poffd->nz; i++) jj[i] = garray[pjj[i]];
+
diff --git a/sci-mathematics/petsc/petsc-3.13.0.ebuild b/sci-mathematics/petsc/petsc-3.13.0.ebuild
new file mode 100644
index 000000000000..961ff927f725
--- /dev/null
+++ b/sci-mathematics/petsc/petsc-3.13.0.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
+
+DESCRIPTION="Portable, Extensible Toolkit for Scientific Computation"
+HOMEPAGE="http://www.mcs.anl.gov/petsc/"
+SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="afterimage boost complex-scalars cxx debug doc fftw
+ fortran hdf5 hypre mpi metis mumps scotch sparse superlu threads X"
+
+# hypre and superlu curretly exclude each other due to missing linking to hypre
+# if both are enabled
+REQUIRED_USE="
+ afterimage? ( X )
+ complex-scalars? ( !hypre !superlu )
+ hdf5? ( mpi )
+ hypre? ( cxx mpi !superlu )
+ mumps? ( mpi scotch )
+ scotch? ( mpi )
+ superlu? ( !hypre )
+"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ afterimage? ( media-libs/libafterimage )
+ boost? ( dev-libs/boost )
+ fftw? ( sci-libs/fftw:3.0[mpi?] )
+ hdf5? ( sci-libs/hdf5[mpi?] )
+ hypre? ( >=sci-libs/hypre-2.18.0[mpi?] )
+ metis? ( >=sci-libs/parmetis-4 )
+ mpi? ( virtual/mpi[cxx?,fortran?] )
+ mumps? ( sci-libs/mumps[mpi?] sci-libs/scalapack )
+ scotch? ( sci-libs/scotch[mpi?] )
+ sparse? ( sci-libs/suitesparse >=sci-libs/cholmod-1.7.0 )
+ superlu? ( >=sci-libs/superlu-5 )
+ X? ( x11-libs/libX11 )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.0-disable-rpath.patch
+ "${FILESDIR}"/${PN}-3.13.0-fix_sandbox_violation.patch
+ "${FILESDIR}"/${PN}-3.13.0-make_hypre_configure.patch
+ "${FILESDIR}"/${PN}-3.13.0-do_not_run_mpiexec.patch
+)
+
+# petsc uses --with-blah=1 and --with-blah=0 to en/disable options
+petsc_enable() {
+ use "$1" && echo "--with-${2:-$1}=1" || echo "--with-${2:-$1}=0"
+}
+# add external library:
+# petsc_with use_flag libname libdir
+# petsc_with use_flag libname include linking_libs
+petsc_with() {
+ local myuse p=${2:-${1}}
+ if use ${1}; then
+ myuse="--with-${p}=1"
+ if [[ $# -ge 4 ]]; then
+ myuse="${myuse} --with-${p}-include=${EPREFIX}${3}"
+ shift 3
+ myuse="${myuse} --with-${p}-lib=$@"
+ else
+ myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
+ fi
+ else
+ myuse="--with-${p}=0"
+ fi
+ echo ${myuse}
+}
+
+# select between configure options depending on use flag
+petsc_select() {
+ use "$1" && echo "--with-$2=$3" || echo "--with-$2=$4"
+}
+
+src_configure() {
+ # bug 548498
+ # PETSc runs mpi processes during configure that result in a sandbox
+ # violation by trying to open /proc/mtrr rw. This is not easy to
+ # mitigate because it happens in libpciaccess.so called by libhwloc.so,
+ # which is used by libmpi.so.
+ addpredict /proc/mtrr
+ # if mpi is built with knem support it needs /dev/knem too
+ addpredict /dev/knem
+
+ # configureMPITypes with openmpi-2* insists on accessing the scaling
+ # governor rw.
+ addpredict /sys/devices/system/cpu/
+
+ local mylang
+ local myopt
+
+ use cxx && mylang="cxx" || mylang="c"
+ use debug && myopt="debug" || myopt="opt"
+
+ # environmental variables expected by petsc during build
+
+ export PETSC_DIR="${S}"
+ export PETSC_ARCH="linux-gnu-${mylang}-${myopt}"
+
+ if use debug; then
+ strip-flags
+ filter-flags -O*
+ fi
+
+ # C Support on CXX builds is enabled if possible i.e. when not using
+ # complex scalars (no complex type for both available at the same time)
+
+ econf \
+ scrollOutput=1 \
+ FFLAGS="${FFLAGS} -fPIC" \
+ CFLAGS="${CFLAGS} -fPIC" \
+ CXXFLAGS="${CXXFLAGS} -fPIC" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/petsc" \
+ --with-shared-libraries \
+ --with-single-library \
+ --with-clanguage=${mylang} \
+ $(use cxx && ! use complex-scalars && echo "with-c-support=1") \
+ --with-petsc-arch=${PETSC_ARCH} \
+ --with-precision=double \
+ --with-gnu-compilers \
+ --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs blas lapack)" \
+ $(petsc_enable debug debugging) \
+ $(petsc_enable mpi) \
+ $(petsc_select mpi cc mpicc $(tc-getCC)) \
+ $(petsc_select mpi cxx mpicxx $(tc-getCXX)) \
+ $(petsc_enable fortran) \
+ $(use fortran && echo "$(petsc_select mpi fc mpif77 $(tc-getF77))") \
+ $(petsc_enable mpi mpi-compilers) \
+ $(petsc_select complex-scalars scalar-type complex real) \
+ --with-windows-graphics=0 \
+ --with-matlab=0 \
+ --with-cmake:BOOL=1 \
+ $(petsc_enable threads pthread) \
+ $(petsc_with afterimage afterimage \
+ /usr/include/libAfterImage -lAfterImage) \
+ $(use_with hdf5) \
+ $(petsc_with hypre hypre \
+ /usr/include/hypre -lHYPRE) \
+ $(use_with sparse suitesparse) \
+ $(petsc_with superlu superlu \
+ /usr/include/superlu -lsuperlu) \
+ $(use_with X x) \
+ $(use_with X x11) \
+ $(petsc_with scotch ptscotch \
+ /usr/include/scotch \
+ [-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
+ $(petsc_with mumps scalapack \
+ /usr/include/scalapack -lscalapack) \
+ $(use_with mumps mumps \
+ /usr/include \
+ [-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
+ --with-imagemagick=0 \
+ --with-python=0 \
+ $(use_with boost) \
+ $(use_with fftw)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99petsc <<- EOF
+ PETSC_DIR=${EPREFIX}/usr/$(get_libdir)/petsc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/petsc/lib
+ EOF
+ doenvd 99petsc
+
+ if use doc ; then
+ docinto html
+ dodoc -r docs/*.html docs/changes docs/manualpages
+ fi
+}