summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-06-01 18:27:54 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-06-01 18:27:54 +0700
commiteba7f5fce9b65ee5cc16b63b99231a56e152f8b5 (patch)
tree9c4344454aa0954f5ad15c3a0ad5311ac50b12df /sci-mathematics
parentsci-mathematics/maxima: bump to 5.43.0 (diff)
downloadgentoo-eba7f5fce9b65ee5cc16b63b99231a56e152f8b5.tar.gz
gentoo-eba7f5fce9b65ee5cc16b63b99231a56e152f8b5.tar.bz2
gentoo-eba7f5fce9b65ee5cc16b63b99231a56e152f8b5.zip
sci-mathematics/wxmaxima: bump to 19.05.7
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-19.05.7.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index d0c4e2921e75..810d7ffaf03e 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-15.08.2.tar.gz 5592673 BLAKE2B cacb508cbcb24e27a43998ba0079b14117980669c25b39b017c0c659ef48d2ad338c6503aea99447a14250ed1a68a3414880828fc8ffdcbd3177b8eb9355a919 SHA512 a537c49477f54df4fd9e4e42a5e0d0d740f1ede817d807a98b7cec877a3ad77b2be0a61ae487a7fa5beb193b112eca163b8873292ecab5acf118d58a91e91af6
DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad25516ea9b0b375daf02edac5518b113188290262bc431e8bfb4836fc1f731982a1c41c62871818e4d2cc68c96ccb31 SHA512 964de93edc5c46e98de3de405b1873fa0ed594d54f1ddc030377b023110261cb1e6b0b08dbf210551888bf890e28d16e9b1698768c93dde413d5e1918cbd234e
DIST wxmaxima-19.03.1.tar.gz 12065575 BLAKE2B a376ac6f8dafd8779b6161695595a3f2fc87e8242086a0f97bfb2823151c198a94c824baa9297dd586271ef121fc9af692b33ac06b2266d58dbbab9212c14d98 SHA512 7aa9e03104d276a1cc753a4edfdc0948822efe3ef93b08090a91efc50efe4ec0d913ff5f87069c1433c18f5b8bf086d025dd6bf7560f3b42a70e883914cc995a
+DIST wxmaxima-19.05.7.tar.gz 13832202 BLAKE2B 6afe37dfcefe3f1711cc1cc89e4c61071dff2d49c60742a6d64ece9fa029823f6e94e20eb69e6d6cd8ccad1f5f656670089d593752f4be4d179222f5f2090d53 SHA512 3a7caee5ab03eefd4d2811345678d7b74081b0a4315dcc7739dbf4d265d274bb47a93ace5980a30185a13f40c1c970a8e4ba444bdd64b8b9ebd3b9a263cc6c06
diff --git a/sci-mathematics/wxmaxima/wxmaxima-19.05.7.ebuild b/sci-mathematics/wxmaxima/wxmaxima-19.05.7.ebuild
new file mode 100644
index 000000000000..6e3b401b1d7f
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-19.05.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg-utils gnome2-utils
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/${1}.po || die "rm ${1}.po failed"
+ }
+ l10n_find_plocales_changes "${S}"/locales '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/wxmaxima.hhp /usr/share/doc/${PF}/wxmaxima_tr.hhp
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}