summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-08-21 15:51:43 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-08-21 15:52:37 +0700
commitebff2caf7690f27661425e9335d7a80ac77d9b00 (patch)
treec61f82909adced4fd83e581e95bb68225d0ae48f /sci-mathematics
parentmedia-sound/qjackctl: bump to 0.6.3, switched to xdg, updated live (diff)
downloadgentoo-ebff2caf7690f27661425e9335d7a80ac77d9b00.tar.gz
gentoo-ebff2caf7690f27661425e9335d7a80ac77d9b00.tar.bz2
gentoo-ebff2caf7690f27661425e9335d7a80ac77d9b00.zip
sci-mathematics/nestedsums: added USE flag static-libs
Closes: https://bugs.gentoo.org/725528 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..99a09d617d4b
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="https://particlephysics.uni-mainz.de/weinzierl/nestedsums/"
+IUSE="doc static-libs"
+SRC_URI="http://particlephysics.uni-mainz.de/weinzierl/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7[static-libs=]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ append-cxxflags -std=c++14
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "cannot rm lib${PN}.la"
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ docinto html
+ dodoc -r reference/html/.
+ fi
+}