summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-05-24 09:29:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-04 19:02:35 +0200
commit2563ac2933be85a58e7bc953e1f80ac0b04f173b (patch)
treea8b18736f74510a271850bf847e6087c4f27cfbd /sci-misc/boinc
parentsci-misc/boinc: Support CURL_SSL="gnutls" (diff)
downloadgentoo-2563ac2933be85a58e7bc953e1f80ac0b04f173b.tar.gz
gentoo-2563ac2933be85a58e7bc953e1f80ac0b04f173b.tar.bz2
gentoo-2563ac2933be85a58e7bc953e1f80ac0b04f173b.zip
sci-misc/boinc: Fix suspend/resume commands in the init script.
Both suspend and resume do not work any more, at least with boinc-7.6.33. The reason is, that fetching the project URLs require password authentication. This commit adds the required steps to no longer get an authentication error when trying to suspend/resume boinc. Closes: https://github.com/gentoo/gentoo/pull/4732 Package-Manager: portage-2.3.6
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.2.44-r4.ebuild (renamed from sci-misc/boinc/boinc-7.2.44-r3.ebuild)0
-rw-r--r--sci-misc/boinc/boinc-7.4.52-r4.ebuild (renamed from sci-misc/boinc/boinc-7.4.52-r3.ebuild)0
-rw-r--r--sci-misc/boinc/boinc-7.6.33-r4.ebuild (renamed from sci-misc/boinc/boinc-7.6.33-r3.ebuild)0
-rw-r--r--sci-misc/boinc/files/boinc.init20
4 files changed, 12 insertions, 8 deletions
diff --git a/sci-misc/boinc/boinc-7.2.44-r3.ebuild b/sci-misc/boinc/boinc-7.2.44-r4.ebuild
index 7a1902920496..7a1902920496 100644
--- a/sci-misc/boinc/boinc-7.2.44-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.2.44-r4.ebuild
diff --git a/sci-misc/boinc/boinc-7.4.52-r3.ebuild b/sci-misc/boinc/boinc-7.4.52-r4.ebuild
index d33072c9535e..d33072c9535e 100644
--- a/sci-misc/boinc/boinc-7.4.52-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.4.52-r4.ebuild
diff --git a/sci-misc/boinc/boinc-7.6.33-r3.ebuild b/sci-misc/boinc/boinc-7.6.33-r4.ebuild
index d33072c9535e..d33072c9535e 100644
--- a/sci-misc/boinc/boinc-7.6.33-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.6.33-r4.ebuild
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index ceeeac87145e..23450a6857cc 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -184,15 +184,17 @@ resume() {
env_check || return 1
local password=""
- local master_urls=( \
- $("${BOINCCMD}" --get_project_status | \
- sed -n 's/\s*master URL: //p') \
- )
if need_passwd_arg; then
password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
fi
+ local master_urls=( \
+ $(cd "${RUNTIMEDIR}" ; \
+ "${BOINCCMD}" ${password} --get_project_status | \
+ sed -n 's/\s*master URL: //p') \
+ )
+
for url in "${master_urls[@]}"; do
ebegin "Resuming $url"
start-stop-daemon --user "${USER}:${GROUP}" --quiet \
@@ -207,15 +209,17 @@ suspend() {
env_check || return 1
local password=""
- local master_urls=( \
- $("${BOINCCMD}" --get_project_status | \
- sed -n 's/\s*master URL: //p') \
- )
if need_passwd_arg; then
password="--passwd \"$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")\""
fi
+ local master_urls=( \
+ $(cd "${RUNTIMEDIR}" ; \
+ "${BOINCCMD}" ${password} --get_project_status | \
+ sed -n 's/\s*master URL: //p') \
+ )
+
for url in "${master_urls[@]}"; do
ebegin "Suspending $url"
start-stop-daemon --user "${USER}:${GROUP}" --quiet \