summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/nco/nco-4.5.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/nco/nco-4.5.1.ebuild')
-rw-r--r--sci-misc/nco/nco-4.5.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-misc/nco/nco-4.5.1.ebuild b/sci-misc/nco/nco-4.5.1.ebuild
new file mode 100644
index 000000000000..599f5f550754
--- /dev/null
+++ b/sci-misc/nco/nco-4.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils flag-o-matic
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+HOMEPAGE="http://nco.sourceforge.net/"
+SRC_URI="http://nco.sf.net/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dap doc gsl ncap2 openmp static-libs test udunits"
+
+RDEPEND="
+ >=sci-libs/netcdf-4:=[dap=,tools]
+ gsl? ( sci-libs/gsl:= )
+ udunits? ( >=sci-libs/udunits-2 )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( dev-java/antlr:0 )
+ test? ( >=sci-libs/netcdf-4[tools] )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-udunits
+ $(use_enable dap dap-netcdf)
+ $(use_enable gsl)
+ $(use_enable ncap2)
+ $(use_enable openmp)
+ $(use_enable udunits udunits2)
+ )
+ if has_version '>=sci-libs/netcdf-4[hdf5]'; then
+ myeconfargs+=( --enable-netcdf4 )
+ append-cppflags -DHAVE_NETCDF4_H
+ else
+ myeconfargs+=( --disable-netcdf4 )
+ fi
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && DOCS=( doc/nco.pdf ) && HTML_DOCS=( doc/nco.html )
+ autotools-utils_src_install
+ doinfo doc/*.info*
+}