summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild')
-rw-r--r--sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild b/sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild
new file mode 100644
index 000000000000..8cc322297728
--- /dev/null
+++ b/sci-misc/netlogo-bin/netlogo-bin-4.0.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils java-pkg-2
+
+MY_PN="netlogo"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Cross-platform multi-agent programmable modeling environment"
+HOMEPAGE="http://ccl.northwestern.edu/netlogo/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${PN/-bin}.gif.tar
+ http://ccl.northwestern.edu/netlogo/${PV}/${MY_P}.tar.gz"
+LICENSE="netlogo"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"/${MY_P}
+
+QA_PREBUILT="/usr/share/"${PN}"/lib/*.so"
+
+src_install() {
+ java-pkg_dojar *.jar
+ java-pkg_dojar extensions/sound/*.jar
+ java-pkg_dojar extensions/profiler/*.jar
+ java-pkg_dojar extensions/array/*.jar
+ java-pkg_dojar extensions/gogo/*.jar
+ java-pkg_dojar extensions/sample/*.jar
+ java-pkg_dojar extensions/table/*.jar
+ java-pkg_dojar extensions/gis/*.jar
+ java-pkg_dojar lib/*.jar
+
+ dohtml -r docs/*
+ insinto /usr/share/"${PN}"/models
+ doins -r models/*
+
+ insinto /usr/share/pixmaps
+ doins "${WORKDIR}"/netlogo.gif
+
+ exeinto /opt/bin
+ newexe "${FILESDIR}"/netlogo.sh netlogo
+
+ make_desktop_entry netlogo "NetLogo" /usr/share/pixmaps/netlogo.gif
+
+ #3D Libs right now only for x86
+ insinto /usr/share/"${PN}"/lib
+ doins lib/*.so
+}