summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2015-12-28 08:02:15 +0100
committerSlawomir Lis <slis@gentoo.org>2015-12-28 08:02:15 +0100
commita63f893dbf166be48fa44e184f20e77aec49a902 (patch)
treeac4277a469ffa5c6f7e0639c62723e1d4477e8ea /sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild
parentdev-ruby/asciidoctor: add 1.5.3 (diff)
downloadgentoo-a63f893dbf166be48fa44e184f20e77aec49a902.tar.gz
gentoo-a63f893dbf166be48fa44e184f20e77aec49a902.tar.bz2
gentoo-a63f893dbf166be48fa44e184f20e77aec49a902.zip
version bump, #569628
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild')
-rw-r--r--sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild b/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild
new file mode 100644
index 000000000000..49fc14dcaa78
--- /dev/null
+++ b/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools flag-o-matic versionator
+
+MY_PV="$(get_version_component_range 1-3)$(get_version_component_range 4)"
+MY_PV=${MY_PV/p/}
+
+DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
+HOMEPAGE="https://github.com/timschmidt/repsnapper"
+SRC_URI="https://github.com/timschmidt/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-cpp/gtkglextmm-1.2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libxmlpp
+ dev-libs/libzip
+ virtual/opengl
+"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}/std-c11.patch"
+ eautoreconf
+ append-cxxflags -std=c++11
+}