summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-12-31 12:59:08 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-12-31 12:59:08 +0700
commitfaa7a828a790c38627847804f3d5ea1a1c47980f (patch)
tree256de4f1eb3ff77371c60aea2e248b10a385a7d9 /sci-misc
parentmedia-libs/lsp-plugins: Stabilize 1.1.22 amd64, #728380 (diff)
downloadgentoo-faa7a828a790c38627847804f3d5ea1a1c47980f.tar.gz
gentoo-faa7a828a790c38627847804f3d5ea1a1c47980f.tar.bz2
gentoo-faa7a828a790c38627847804f3d5ea1a1c47980f.zip
sci-misc/cdfplayer: bump to 12.2.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/cdfplayer/Manifest1
-rw-r--r--sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sci-misc/cdfplayer/Manifest b/sci-misc/cdfplayer/Manifest
index cb91835ca78f..43586506a2dd 100644
--- a/sci-misc/cdfplayer/Manifest
+++ b/sci-misc/cdfplayer/Manifest
@@ -1,2 +1,3 @@
DIST CDFPlayer_11.2.0_LINUX.sh 1821479711 BLAKE2B 7d12a94b43fdd60dc6af3d78fe45f85a2aa68752c690de023d4cd0cc5d24f8b091db7846d3732d7618d7df659b982fbcf19543d7d0c0116ddcae7f7b1aa11d88 SHA512 8a9a98ed5dceb18db41e52269dedf2a00ee89015a76eb650b852f8e1c19040918ecfa7594737f2982118c7358eab4d1e85694eecbe059edc963d4bdc8533b470
DIST CDFPlayer_11.3.0_LINUX.sh 1556151070 BLAKE2B 652adda3989bdac10f02c5fc648ded7189e56555bab9d48f75c642a9ca6b0ca70771cae54142f55bc2d19a720a17fad04abd3c7240a114a237dee69e4f8ca303 SHA512 d28939481772e1a2ec6296b5f4d7e98628ccc015c75c084b09a90937525415c6a447111c1488482bf355917ac2ddb8dc154f46b8864d0d001bb7d419cd2f671a
+DIST WolframPlayer_12.2.0_LINUX.sh 1003754320 BLAKE2B b37e2500e09543efd5084b6fadd6f5d6d6f7f2b75627fc8cb3819578d41de00a8ba5f529440d64efebabcf9d26a77b51b01969135f02baca851c42811ef521b7 SHA512 dc4449836419dd7abe8590319912b07019a4f2cf542e31759c15bde0055bfc6bebc880fd6ab88809758d5723862bbbe971affa07429a660b728698d24a4c9d20
diff --git a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
new file mode 100644
index 000000000000..6120fae9e88b
--- /dev/null
+++ b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib versionator
+
+DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
+SRC_URI="WolframPlayer_12.2.0_LINUX.sh"
+HOMEPAGE="http://www.wolfram.com/cdf-player/"
+
+LICENSE="WolframCDFPlayer"
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RESTRICT="strip mirror bindist fetch"
+
+DEPEND=""
+
+# this list comes from lsof output
+# probably there are still some libraries missing
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ media-libs/alsa-lib
+ dev-libs/expat
+ media-libs/fontconfig
+ dev-libs/icu
+ x11-libs/libxcb
+ dev-libs/libxml2
+ sys-libs/ncurses-compat:5
+ media-libs/freetype
+"
+
+# we need this a few times
+MPN="WolframPlayer"
+MPV=$(get_version_component_range 1-2)
+
+# we might as well list all files in all QA variables...
+QA_PREBUILT="opt/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ /bin/sh "${DISTDIR}/${A}" --nox11 --confirm --keep -- -auto "-targetdir=${S}/opt/Wolfram/${MPN}/${MPV}" "-execdir=${S}/opt/bin" || die
+}
+
+src_install() {
+ local ARCH
+ if use amd64; then ARCH='-x86-64'; else ARCH=''; fi
+
+ # move all over
+ mv "${S}"/opt "${D}"/opt || die
+
+ # the autogenerated symlinks point into sandbox, redo
+ rm "${D}"/opt/bin/* || die
+ dosym ../Wolfram/${MPN}/${MPV}/Executables/wolframplayer opt/bin/wolframplayer
+ dosym ../Wolfram/${MPN}/${MPV}/Executables/WolframPlayer opt/bin/WolframPlayer
+
+ # fix some embedded paths and install desktop files
+ insinto /usr/share/applications
+ for filename in $(find "${D}" -name "wolfram-cdf12.desktop") ; do
+ echo Fixing "${filename}"
+ sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
+ echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+ doins "${filename}"
+ done
+
+ # install a wrapper
+ echo '#!/bin/sh' >> ${PN}
+ echo "LD_PRELOAD=/usr/$(get_libdir)/libfreetype.so.6:/lib/libz.so.1 /opt/Wolfram/${MPN}/${MPV}/Executables/wolframplayer \$*" \
+ >> ${PN}
+ dobin ${PN}
+}
+
+pkg_nofetch() {
+ einfo "Sadly Wolfram provides no permanent link to the player files."
+ einfo "Please download the Wolfram CFD Player installation file ${SRC_URI} from"
+ einfo "${HOMEPAGE} and place it into your DISTDIR directory."
+}