summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-17 20:46:46 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-17 20:47:32 -0600
commit22044f9db79ebf0b06715cb505fab32241c77dbe (patch)
tree2eae53ff73d1349a74e443b2ca0db1c9c54e03db /sci-physics/espresso++/espresso++-9999.ebuild
parentapp-office/lyx: fix missing dev-qt/qtconcurrent dep (diff)
downloadgentoo-22044f9db79ebf0b06715cb505fab32241c77dbe.tar.gz
gentoo-22044f9db79ebf0b06715cb505fab32241c77dbe.tar.bz2
gentoo-22044f9db79ebf0b06715cb505fab32241c77dbe.zip
sci-physics/espresso++: imported live ebuild from sci
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/espresso++/espresso++-9999.ebuild')
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
new file mode 100644
index 000000000000..fdce52343004
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
+HOMEPAGE="https://www.espresso-pp.de"
+
+MY_PN="${PN//+/p}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git http://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ dev-python/mpi4py"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}