summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-27 11:10:13 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-27 11:10:29 -0600
commit23d148c25f606f2804c114c5f4355b72f10294bc (patch)
tree04ce0854682576b21b2ad7b798b4b7d21a5d19b0 /sci-physics/espresso++/espresso++-9999.ebuild
parentsci-physics/hoomd-blue: live ebuild update (diff)
downloadgentoo-23d148c25f606f2804c114c5f4355b72f10294bc.tar.gz
gentoo-23d148c25f606f2804c114c5f4355b72f10294bc.tar.bz2
gentoo-23d148c25f606f2804c114c5f4355b72f10294bc.zip
sci-physics/espresso++: live ebuild update
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/espresso++/espresso++-9999.ebuild')
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
index fdce52343004..3d3ecff7e9ee 100644
--- a/sci-physics/espresso++/espresso++-9999.ebuild
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils python-single-r1
+inherit cmake-utils python-r1
DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
HOMEPAGE="https://www.espresso-pp.de"
@@ -31,14 +31,29 @@ RDEPEND="${PYTHON_DEPS}
virtual/mpi
dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
sci-libs/fftw:3.0
- dev-python/mpi4py"
+ dev-python/mpi4py[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
src_configure() {
- local mycmakeargs=(
- -DEXTERNAL_BOOST=ON
- -DEXTERNAL_MPI4PY=ON
- -DWITH_RC_FILES=OFF
- )
- cmake-utils_src_configure
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
}