summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /sci-physics/geant-vmc
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-physics/geant-vmc')
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.3.6-r1.ebuild8
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild8
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/sci-physics/geant-vmc/geant-vmc-4.3.6-r1.ebuild b/sci-physics/geant-vmc/geant-vmc-4.3.6-r1.ebuild
index b92483ba721f..585f02e1660a 100644
--- a/sci-physics/geant-vmc/geant-vmc-4.3.6-r1.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-4.3.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -52,11 +52,11 @@ src_configure() {
-DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
-DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc ; then
local dirs=(
source
@@ -83,7 +83,7 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && local HTML_DOCS=(doc/.)
einstalldocs
}
diff --git a/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild b/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
index 0f091fe6412e..fb2e982ebfd8 100644
--- a/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -55,11 +55,11 @@ src_configure() {
-DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
-DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc ; then
local dirs=(
source
@@ -90,7 +90,7 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && local HTML_DOCS=(doc/.)
einstalldocs
}
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
index ffc8e7dc8743..9c27c2d98efa 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -52,11 +52,11 @@ src_configure() {
-DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
-DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc ; then
local dirs=(
source
@@ -83,7 +83,7 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && local HTML_DOCS=(doc/.)
einstalldocs
}