summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-05-05 22:38:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-05-05 23:11:03 +0200
commit43524c9b7983800ae991b5d295d2588e3db50c2e (patch)
tree10ffe0f2371eb80a00fe5f27e039d04e2ca0ee79 /sci-physics/geant
parentdev-python/visual: Require USE="threads" for dev-libs/boost (diff)
downloadgentoo-43524c9b7983800ae991b5d295d2588e3db50c2e.tar.gz
gentoo-43524c9b7983800ae991b5d295d2588e3db50c2e.tar.bz2
gentoo-43524c9b7983800ae991b5d295d2588e3db50c2e.zip
sci-physics/geant: Add std:: qualifier to isnan for C++11
Gentoo-Bug: 581322 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/files/geant-4.10.02-std-isnan.patch17
-rw-r--r--sci-physics/geant/geant-4.10.02.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/sci-physics/geant/files/geant-4.10.02-std-isnan.patch b/sci-physics/geant/files/geant-4.10.02-std-isnan.patch
new file mode 100644
index 000000000000..6d26a6c2c0d0
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.02-std-isnan.patch
@@ -0,0 +1,17 @@
+Fully qualify isnan:
+* /var/tmp/portage/sci-physics/geant-4.10.02/work/geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc:61:22: error: ‘isnan’ was not declared in this scope
+* return( isnan( d ) );
+See also:
+https://bugs.gentoo.org/show_bug.cgi?id=581322
+
+--- geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc
++++ geant4.10.02/source/processes/hadronic/models/lend/src/nf_utilities.cc
+@@ -58,7 +58,7 @@
+ */
+ int nfu_isNAN( double d ) {
+
+- return( isnan( d ) );
++ return( std::isnan( d ) );
+ }
+ /*
+ ************************************************************
diff --git a/sci-physics/geant/geant-4.10.02.ebuild b/sci-physics/geant/geant-4.10.02.ebuild
index 5dd41eeef36a..89b1e1220a30 100644
--- a/sci-physics/geant/geant-4.10.02.ebuild
+++ b/sci-physics/geant/geant-4.10.02.ebuild
@@ -41,6 +41,7 @@ PDEPEND="
S="${WORKDIR}/${MYP}"
src_prepare() {
+ epatch -p1 "${FILESDIR}/${P}-std-isnan.patch"
use examples || epatch "${FILESDIR}"/${PN}-${PV1}.${PV2}.${SPV3}-no-examples.patch
}